summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-11-05 21:39:42 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-11-05 21:39:42 +0000
commit727fa40e37a7e40ab68f76e01716fe6ef25e269a (patch)
tree8c2d0e8c24c4c60160e5c1fc5087873e553671d0 /app-text/bibletime/bibletime-2.3.3.ebuild
parentBump for #284274 (diff)
downloadgentoo-2-727fa40e37a7e40ab68f76e01716fe6ef25e269a.tar.gz
gentoo-2-727fa40e37a7e40ab68f76e01716fe6ef25e269a.tar.bz2
gentoo-2-727fa40e37a7e40ab68f76e01716fe6ef25e269a.zip
Bump for #290875
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'app-text/bibletime/bibletime-2.3.3.ebuild')
-rw-r--r--app-text/bibletime/bibletime-2.3.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/bibletime/bibletime-2.3.3.ebuild b/app-text/bibletime/bibletime-2.3.3.ebuild
new file mode 100644
index 000000000000..87be2b536274
--- /dev/null
+++ b/app-text/bibletime/bibletime-2.3.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/bibletime-2.3.3.ebuild,v 1.1 2009/11/05 21:39:42 patrick Exp $
+
+EAPI=2
+
+inherit cmake-utils
+
+DESCRIPTION="Qt4 Bible study application using the SWORD library."
+HOMEPAGE="http://www.bibletime.info/"
+SRC_URI="mirror://sourceforge/bibletime/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=app-text/sword-1.6.0
+ >=dev-cpp/clucene-0.9.16a
+ dev-libs/boost
+ >=x11-libs/qt-core-4.4.0:4
+ >=x11-libs/qt-dbus-4.4.0:4
+ >=x11-libs/qt-gui-4.4.0:4
+ >=x11-libs/qt-svg-4.4.0:4
+ >=x11-libs/qt-webkit-4.4.0:4"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.6.0
+ >=x11-libs/qt-test-4.4.0:4"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DUSE_QT_WEBKIT=ON"
+ cmake-utils_src_configure
+}