summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-10-08 00:24:19 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-10-08 00:24:19 +0000
commitb0c85f1eb04f067798316a95a011e7e51429356f (patch)
tree1dddfbe02717183bd9965d43ea54b07425a6f40c /app-text/cabocha
parentRevert!Revert! (diff)
downloadgentoo-2-b0c85f1eb04f067798316a95a011e7e51429356f.tar.gz
gentoo-2-b0c85f1eb04f067798316a95a011e7e51429356f.tar.bz2
gentoo-2-b0c85f1eb04f067798316a95a011e7e51429356f.zip
Version bumped, bug #239605. Clean up.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'app-text/cabocha')
-rw-r--r--app-text/cabocha/ChangeLog9
-rw-r--r--app-text/cabocha/cabocha-0.60_pre4.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/app-text/cabocha/ChangeLog b/app-text/cabocha/ChangeLog
index 258487d5abe5..21bca59d9728 100644
--- a/app-text/cabocha/ChangeLog
+++ b/app-text/cabocha/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/cabocha
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/cabocha/ChangeLog,v 1.4 2006/11/02 19:11:44 usata Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/cabocha/ChangeLog,v 1.5 2008/10/08 00:24:19 matsuu Exp $
+
+*cabocha-0.60_pre4 (08 Oct 2008)
+
+ 08 Oct 2008; MATSUU Takuto <matsuu@gentoo.org> +cabocha-0.60_pre4.ebuild:
+ Version bumped, bug #239605. Clean up.
02 Nov 2006; Mamoru KOMACHI <usata@gentoo.org> -cabocha-0.52.ebuild,
cabocha-0.53.ebuild:
diff --git a/app-text/cabocha/cabocha-0.60_pre4.ebuild b/app-text/cabocha/cabocha-0.60_pre4.ebuild
new file mode 100644
index 000000000000..72a882c10186
--- /dev/null
+++ b/app-text/cabocha/cabocha-0.60_pre4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/cabocha/cabocha-0.60_pre4.ebuild,v 1.1 2008/10/08 00:24:19 matsuu Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit autotools eutils multilib
+
+MY_P="${P/_}"
+DESCRIPTION="Yet Another Japanese Dependency Structure Analyzer"
+HOMEPAGE="http://chasen.org/~taku/software/cabocha/"
+SRC_URI="mirror://sourceforge/cabocha/${MY_P}.tar.bz2"
+
+LICENSE="|| ( LGPL-2.1 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+#IUSE="java perl python ruby unicode"
+IUSE="unicode"
+
+DEPEND="app-text/crf++
+ app-text/mecab"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "/^modeldir/s|lib|$(get_libdir)|" model/Makefile.am || die
+ eautoreconf
+}
+
+src_compile() {
+ local myconf
+ use unicode && myconf="${myconf} --with-charset=UTF8"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README TODO
+}