summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-02-08 12:30:20 +0000
committerMamoru Komachi <usata@gentoo.org>2005-02-08 12:30:20 +0000
commitcc2b5d28e1da844be9e9568bdacfb2236555d0aa (patch)
tree6e70b2bd638cd262a99cc5fd96a658f3ce2a6e1e /app-text/catdoc/catdoc-0.93.4.ebuild
parentVersion bumped. This closes bug #75069. (diff)
downloadgentoo-2-cc2b5d28e1da844be9e9568bdacfb2236555d0aa.tar.gz
gentoo-2-cc2b5d28e1da844be9e9568bdacfb2236555d0aa.tar.bz2
gentoo-2-cc2b5d28e1da844be9e9568bdacfb2236555d0aa.zip
Version bumped. This closes bug #76316.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-text/catdoc/catdoc-0.93.4.ebuild')
-rw-r--r--app-text/catdoc/catdoc-0.93.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-text/catdoc/catdoc-0.93.4.ebuild b/app-text/catdoc/catdoc-0.93.4.ebuild
new file mode 100644
index 000000000000..11030f0bff76
--- /dev/null
+++ b/app-text/catdoc/catdoc-0.93.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/catdoc/catdoc-0.93.4.ebuild,v 1.1 2005/02/08 12:30:20 usata Exp $
+
+DESCRIPTION="A convertor for Microsoft Word, Excel and RTF Files to text"
+HOMEPAGE="http://www.45.free.net/~vitus/ice/catdoc/"
+SRC_URI="ftp://ftp.45.free.net/pub/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+IUSE="tcltk"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="tcltk? ( >=dev-lang/tk-8.1 )"
+
+DOCS="CODING.STD COPYING CREDITS INSTALL NEWS README TODO"
+
+src_compile() {
+
+ local myconf="--with-install-root=${D}"
+
+ use tcltk \
+ && myconf="${myconf} --with-wish=/usr/bin/wish" \
+ || myconf="${myconf} --disable-wordview"
+
+ econf ${myconf} || die
+ emake LIB_DIR=/usr/share/catdoc || die
+
+}
+
+src_install() {
+
+ make mandir=/usr/share/man/man1 install || die
+ dodoc ${DOCS}
+
+}
+
+