summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Touceda <chiiph@gentoo.org>2010-10-06 20:22:26 +0000
committerTomás Touceda <chiiph@gentoo.org>2010-10-06 20:22:26 +0000
commit9c59030143eb8299d0b47896f33c1ca2b9f8039d (patch)
treee6f9d979f9eeda319888b1ccb6644ca0692f4368 /app-text/cb2bib
parentx86 stable, bug #338934 (diff)
downloadgentoo-2-9c59030143eb8299d0b47896f33c1ca2b9f8039d.tar.gz
gentoo-2-9c59030143eb8299d0b47896f33c1ca2b9f8039d.tar.bz2
gentoo-2-9c59030143eb8299d0b47896f33c1ca2b9f8039d.zip
Version bump
(Portage version: 2.2_rc88/cvs/Linux i686)
Diffstat (limited to 'app-text/cb2bib')
-rw-r--r--app-text/cb2bib/ChangeLog7
-rw-r--r--app-text/cb2bib/cb2bib-1.4.2.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/app-text/cb2bib/ChangeLog b/app-text/cb2bib/ChangeLog
index e4d3b5ad1a8e..dc002348501c 100644
--- a/app-text/cb2bib/ChangeLog
+++ b/app-text/cb2bib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/cb2bib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/cb2bib/ChangeLog,v 1.5 2010/04/29 06:21:51 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/cb2bib/ChangeLog,v 1.6 2010/10/06 20:22:26 chiiph Exp $
+
+*cb2bib-1.4.2 (06 Oct 2010)
+
+ 06 Oct 2010; Tomas Touceda <chiiph@gentoo.org> +cb2bib-1.4.2.ebuild:
+ Version bump
*cb2bib-1.4.0 (29 Apr 2010)
diff --git a/app-text/cb2bib/cb2bib-1.4.2.ebuild b/app-text/cb2bib/cb2bib-1.4.2.ebuild
new file mode 100644
index 000000000000..ebe19a3befd3
--- /dev/null
+++ b/app-text/cb2bib/cb2bib-1.4.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/cb2bib/cb2bib-1.4.2.ebuild,v 1.1 2010/10/06 20:22:26 chiiph Exp $
+
+EAPI="2"
+
+inherit qt4-r2
+
+DESCRIPTION="Tool for extracting unformatted bibliographic references"
+HOMEPAGE="http://www.molspaces.com/cb2bib/"
+SRC_URI="http://www.molspaces.com/dl/progs/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +lzo +poll"
+
+DEPEND="x11-libs/qt-webkit:4
+ lzo? ( dev-libs/lzo )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ echo "CONFIG += ordered" >> "${PN}.pro" || die "patching project file failed"
+ sed -i 's:\.\./COPYRIGHT \.\.\/LICENSE::' src/src.pro || die "sed src.pro failed"
+}
+
+src_configure() {
+ # Custom configure script has only few options, so call ./configure manually...
+ # We need to unset QTDIR here, else we may end up with qt3 if it is installed.
+ # TODO: remove QTDIR when qt3 goes away
+ QTDIR="" ./configure \
+ $(use_enable lzo) \
+ $(use_enable poll cbpoll) \
+ --disable-qmake-call \
+ --qmakepath /usr/bin/qmake \
+ --prefix /usr \
+ --bindir /usr/bin \
+ --datadir /usr/share \
+ --desktopdatadir /usr/share/applications \
+ --icondir /usr/share/pixmaps \
+ || die "cb2bib-provided configure failed"
+
+ eqmake4 $(cat qmake-additional-args)
+}
+
+pkg_postinst() {
+ elog "For best functionality, emerge the following packages:"
+ elog " app-text/poppler-utils - for data import from PDF files"
+ elog " app-text/dvipdfm - for data import from DVI files"
+ elog " app-text/bibutils - for data import from ISI, endnote format"
+ elog " media-fonts/jsmath - for displaying mathematical notation"
+ elog " media-libs/exiftool - for proper UTF-8 metadata writing in PDF"
+ elog " text strings"
+ elog " virtual/latex-base - to check for BibTeX file correctness and to get"
+ elog " nice printing through the shell script bib2pdf"
+}