summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-09-14 17:59:35 +0000
committerPeter Volkov <pva@gentoo.org>2008-09-14 17:59:35 +0000
commitf3d098b9ca0facf48c6d94fac6376f458c3df21b (patch)
tree42f2585090f3a9474a6e80eff100cfaff494625a /app-text/djvu/files
parentbump (bug 236201), try without -j1 (bug 236010) (diff)
downloadgentoo-2-f3d098b9ca0facf48c6d94fac6376f458c3df21b.tar.gz
gentoo-2-f3d098b9ca0facf48c6d94fac6376f458c3df21b.tar.bz2
gentoo-2-f3d098b9ca0facf48c6d94fac6376f458c3df21b.zip
Fix parallel build, bug #236418, thank Walter Meinl for report.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'app-text/djvu/files')
-rw-r--r--app-text/djvu/files/djvu-3.5.21-parallel-build.patch78
1 files changed, 78 insertions, 0 deletions
diff --git a/app-text/djvu/files/djvu-3.5.21-parallel-build.patch b/app-text/djvu/files/djvu-3.5.21-parallel-build.patch
new file mode 100644
index 000000000000..0d305058a558
--- /dev/null
+++ b/app-text/djvu/files/djvu-3.5.21-parallel-build.patch
@@ -0,0 +1,78 @@
+Author: Peter Volkov <pva@gentoo.org>
+Upstream: notified: https://sourceforge.net/tracker/?func=detail&atid=406585&aid=2110660&group_id=32953
+Reason: parallel build failes, bug #236418
+
+=== modified file 'i18n/cs/Makefile.in'
+--- i18n/cs/Makefile.in 2008-09-14 12:06:27 +0000
++++ i18n/cs/Makefile.in 2008-09-14 12:11:48 +0000
+@@ -98,6 +98,6 @@
+
+ .ts.qm:
+ if test ${LRELEASE} = ":" ; then : ; else \
+- echo TRANSLATIONS=tmp.ts > tmp.pro && \
+- cp $< tmp.ts && ${LRELEASE} tmp.pro && cp tmp.qm $@ && \
+- ${RM} tmp.qm tmp.ts tmp.pro ; fi
++ echo TRANSLATIONS=$@.tmp.ts > $@.tmp.pro && \
++ cp $< $@.tmp.ts && ${LRELEASE} $@.tmp.pro && cp $@.tmp.qm $@ && \
++ ${RM} $@.tmp.qm $@.tmp.ts $@.tmp.pro ; fi
+
+=== modified file 'i18n/de/Makefile.in'
+--- i18n/de/Makefile.in 2008-09-14 12:06:27 +0000
++++ i18n/de/Makefile.in 2008-09-14 12:11:42 +0000
+@@ -65,7 +65,7 @@
+ done
+
+ # Install localized man pages
+-install-man: FORCE ${NSDEJAVU1}
++install-man: FORCE ${NSDEJAVU1}
+ test ${LANGCODE} != dummy
+ -${INSTALL} -d ${man}
+ -for n in ${MANFILES} ; do \
+@@ -98,6 +98,6 @@
+
+ .ts.qm:
+ if test ${LRELEASE} = ":" ; then : ; else \
+- echo TRANSLATIONS=tmp.ts > tmp.pro && \
+- cp $< tmp.ts && ${LRELEASE} tmp.pro && cp tmp.qm $@ && \
+- ${RM} tmp.qm tmp.ts tmp.pro ; fi
++ echo TRANSLATIONS=$@.tmp.ts > $@.tmp.pro && \
++ cp $< $@.tmp.ts && ${LRELEASE} $@.tmp.pro && cp $@.tmp.qm $@ && \
++ ${RM} $@.tmp.qm $@.tmp.ts $@.tmp.pro ; fi
+
+=== modified file 'i18n/fr/Makefile.in'
+--- i18n/fr/Makefile.in 2008-09-14 12:06:27 +0000
++++ i18n/fr/Makefile.in 2008-09-14 12:11:32 +0000
+@@ -98,6 +98,6 @@
+
+ .ts.qm:
+ if test ${LRELEASE} = ":" ; then : ; else \
+- echo TRANSLATIONS=tmp.ts > tmp.pro && \
+- cp $< tmp.ts && ${LRELEASE} tmp.pro && cp tmp.qm $@ && \
+- ${RM} tmp.qm tmp.ts tmp.pro ; fi
++ echo TRANSLATIONS=$@.tmp.ts > $@.tmp.pro && \
++ cp $< $@.tmp.ts && ${LRELEASE} $@.tmp.pro && cp $@.tmp.qm $@ && \
++ ${RM} $@.tmp.qm $@.tmp.ts $@.tmp.pro ; fi
+
+=== modified file 'i18n/ja/Makefile.in'
+--- i18n/ja/Makefile.in 2008-09-14 12:06:27 +0000
++++ i18n/ja/Makefile.in 2008-09-14 15:41:54 +0000
+@@ -46,7 +46,7 @@
+ # (uncomment after translating nsdejavu.1.in)
+ NSDEJAVU1= nsdejavu.1
+
+-all:
++all:
+ @GUI_YES@all: ${QMFILES} ${NSDEJAVU1}
+
+ @GUI_YES@install: install-qm
+@@ -99,6 +99,6 @@
+
+ .ts.qm:
+ if test ${LRELEASE} = ":" ; then : ; else \
+- echo TRANSLATIONS=tmp.ts > tmp.pro && \
+- cp $< tmp.ts && ${LRELEASE} tmp.pro && cp tmp.qm $@ && \
+- ${RM} tmp.qm tmp.ts tmp.pro ; fi
++ echo TRANSLATIONS=$@.tmp.ts > $@.tmp.pro && \
++ cp $< $@.tmp.ts && ${LRELEASE} $@.tmp.pro && cp $@.tmp.qm $@ && \
++ ${RM} $@.tmp.qm $@.tmp.ts $@.tmp.pro ; fi
+