summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-28 04:03:38 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-28 04:03:38 +0000
commit59e70743cc92b4299493d80da7ccd11bbfdb3c3b (patch)
tree1fcbf05e7425ca18392ac8d3997d57fa1ceb2678 /app-text/docbook-dsssl-stylesheets
parentNew version (diff)
downloadgentoo-2-59e70743cc92b4299493d80da7ccd11bbfdb3c3b.tar.gz
gentoo-2-59e70743cc92b4299493d80da7ccd11bbfdb3c3b.tar.bz2
gentoo-2-59e70743cc92b4299493d80da7ccd11bbfdb3c3b.zip
cleanup
Diffstat (limited to 'app-text/docbook-dsssl-stylesheets')
-rw-r--r--app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.64.ebuild49
1 files changed, 29 insertions, 20 deletions
diff --git a/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.64.ebuild b/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.64.ebuild
index 6e0a1e2c645f..cbedb1fbf95e 100644
--- a/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.64.ebuild
+++ b/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.64.ebuild
@@ -1,40 +1,49 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.64.ebuild,v 1.3 2001/12/10 09:55:08 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.64.ebuild,v 1.4 2002/04/28 03:59:29 seemant Exp $
-A="db164.zip"
+MY_P="db164"
S=${WORKDIR}/docbook
DESCRIPTION=""
-SRC_URI="http://www.nwalsh.com/docbook/dsssl/${A}"
+SRC_URI="http://www.nwalsh.com/docbook/dsssl/${MY_P}.zip"
HOMEPAGE="http://www.nwalsh.com/docbook/dsssl/"
DEPEND=">=app-arch/unzip-5.41"
RDEPEND="app-text/sgml-common"
-src_unpack() {
-
- unpack ${A}
- cp ${FILESDIR}/${P}.Makefile ${S}/Makefile
-
-}
-
src_install () {
- try make BINDIR="${D}/usr/bin" DESTDIR="${D}/usr/share/sgml/docbook/dsssl-stylesheets-${PV}" install
+ cp ${FILESDIR}/${P}.Makefile .
+
+ make \
+ BINDIR="${D}/usr/bin" \
+ DESTDIR="${D}/usr/share/sgml/docbook/dsssl-stylesheets-${PV}" \
+ install || die
}
pkg_postinst() {
- if [ -x "/usr/bin/install-catalog" ] && [ "$ROOT" = "/" ] ; then
- install-catalog --add /etc/sgml/dsssl-docbook-stylesheets.cat /usr/share/sgml/docbook/dsssl-stylesheets-${PV}/catalog
- install-catalog --add /etc/sgml/sgml-docbook.cat /etc/sgml/dsssl-docbook-stylesheets.cat
- fi
+ if [ -x "/usr/bin/install-catalog" ] && [ "$ROOT" = "/" ]
+ then
+ install-catalog --add \
+ /etc/sgml/dsssl-docbook-stylesheets.cat \
+ /usr/share/sgml/docbook/dsssl-stylesheets-${PV}/catalog
+
+ install-catalog --add \
+ /etc/sgml/sgml-docbook.cat \
+ /etc/sgml/dsssl-docbook-stylesheets.cat
+ fi
}
pkg_prerm() {
- if [ -x "/usr/bin/install-catalog" ] && [ "$ROOT" = "/" ] ; then
- install-catalog --remove /etc/sgml/dsssl-docbook-stylesheets.cat /usr/share/sgml/docbook/dsssl-stylesheets-${PV}/catalog
- install-catalog --remove /etc/sgml/sgml-docbook.cat /etc/sgml/dsssl-docbook-stylesheets.cat
- fi
+ if [ -x "/usr/bin/install-catalog" ] && [ "$ROOT" = "/" ]
+ then
+ install-catalog --remove \
+ /etc/sgml/dsssl-docbook-stylesheets.cat \
+ /usr/share/sgml/docbook/dsssl-stylesheets-${PV}/catalog
+ install-catalog --remove \
+ /etc/sgml/sgml-docbook.cat \
+ /etc/sgml/dsssl-docbook-stylesheets.cat
+ fi
}