summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-09-11 05:20:14 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-09-11 05:20:14 +0000
commitbd6cc60bf4b22ad48798c0e262676eea43def4bf (patch)
tree42a9b4b738a30ea02572dbb00ce1691f5397ef8d /app-text/dos2unix
parentDelete bogus hunk that creates a .rej file #522102 by Anthony Basile. (diff)
downloadgentoo-2-bd6cc60bf4b22ad48798c0e262676eea43def4bf.tar.gz
gentoo-2-bd6cc60bf4b22ad48798c0e262676eea43def4bf.tar.bz2
gentoo-2-bd6cc60bf4b22ad48798c0e262676eea43def4bf.zip
Move dependency for test run from RDEPEND to DEPEND
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'app-text/dos2unix')
-rw-r--r--app-text/dos2unix/ChangeLog10
-rw-r--r--app-text/dos2unix/dos2unix-7.0.ebuild60
2 files changed, 69 insertions, 1 deletions
diff --git a/app-text/dos2unix/ChangeLog b/app-text/dos2unix/ChangeLog
index b4c62def6cb0..c80a645d841d 100644
--- a/app-text/dos2unix/ChangeLog
+++ b/app-text/dos2unix/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/dos2unix
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.144 2014/08/27 12:24:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.145 2014/09/11 05:20:14 polynomial-c Exp $
+
+ 11 Sep 2014; Lars Wendler <polynomial-c@gentoo.org> +dos2unix-7.0.ebuild:
+ Move dependency for test run from RDEPEND to DEPEND.
+
+*dos2unix-7.0 (10 Sep 2014)
+
+ 10 Sep 2014; Lars Wendler <polynomial-c@gentoo.org> +dos2unix-7.0.ebuild:
+ Version bump.
27 Aug 2014; Agostino Sarubbo <ago@gentoo.org> dos2unix-6.0.5.ebuild:
Stable for ppc, wrt bug #519022
diff --git a/app-text/dos2unix/dos2unix-7.0.ebuild b/app-text/dos2unix/dos2unix-7.0.ebuild
new file mode 100644
index 000000000000..2bfacaa058c2
--- /dev/null
+++ b/app-text/dos2unix/dos2unix-7.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/dos2unix-7.0.ebuild,v 1.1 2014/09/11 05:20:14 polynomial-c Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
+HOMEPAGE="http://www.xs4all.nl/~waterlan/dos2unix.html http://sourceforge.net/projects/dos2unix/"
+SRC_URI="
+ http://www.xs4all.nl/~waterlan/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="debug nls test"
+
+RDEPEND="
+ !app-text/hd2u
+ !app-text/unix2dos
+ virtual/libintl"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ test? ( virtual/perl-Test-Simple )
+ dev-lang/perl"
+
+src_prepare() {
+ sed \
+ -e '/^LDFLAGS/s|=|+=|' \
+ -e '/CFLAGS_OS \+=/d' \
+ -e '/LDFLAGS_EXTRA \+=/d' \
+ -e "/^CFLAGS/s|-O2|${CFLAGS}|" \
+ -i Makefile || die
+
+ if use debug ; then
+ sed -e "/^DEBUG/s:0:1:" \
+ -e "/EXTRA_CFLAGS +=/s:-g::" \
+ -i Makefile || die
+ fi
+
+ tc-export CC
+}
+
+lintl() {
+ # same logic as from virtual/libintl
+ use !elibc_glibc && use !elibc_uclibc && echo "-lintl"
+}
+
+src_compile() {
+ emake prefix="${EPREFIX}/usr" \
+ $(usex nls "LDFLAGS_EXTRA=$(lintl)" "ENABLE_NLS=")
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
+ $(usex nls "" "ENABLE_NLS=") install
+}