summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-08-12 16:33:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-08-12 16:33:18 +0000
commit2cd77eef59fc90cc8e48e4dd5cd7737d0b95172d (patch)
tree75b8c6c5163416fb2193881e6d81f2dd904ab301 /app-text/gpdf
parentAdding a patch that actually allows to compile on ppc-macos (was already mark... (diff)
downloadgentoo-2-2cd77eef59fc90cc8e48e4dd5cd7737d0b95172d.tar.gz
gentoo-2-2cd77eef59fc90cc8e48e4dd5cd7737d0b95172d.tar.bz2
gentoo-2-2cd77eef59fc90cc8e48e4dd5cd7737d0b95172d.zip
resurrect gpdf-2.10.0.ebuild until -r1 is stable
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-text/gpdf')
-rw-r--r--app-text/gpdf/ChangeLog5
-rw-r--r--app-text/gpdf/files/digest-gpdf-2.10.01
-rw-r--r--app-text/gpdf/gpdf-2.10.0.ebuild55
3 files changed, 60 insertions, 1 deletions
diff --git a/app-text/gpdf/ChangeLog b/app-text/gpdf/ChangeLog
index 94082a535eee..1f1524d6a60c 100644
--- a/app-text/gpdf/ChangeLog
+++ b/app-text/gpdf/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/gpdf
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gpdf/ChangeLog,v 1.98 2005/08/12 16:19:42 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gpdf/ChangeLog,v 1.99 2005/08/12 16:33:18 mr_bones_ Exp $
+
+ 12 Aug 2005; Michael Sterrett <mr_bones_@gentoo.org> +gpdf-2.10.0.ebuild:
+ resurrect gpdf-2.10.0.ebuild until -r1 is stable
12 Aug 2005; Luis Medinas <metalgod@gentoo.org> gpdf-2.10.0-r1.ebuild:
Stable on AMD64. Fix bug #100265.
diff --git a/app-text/gpdf/files/digest-gpdf-2.10.0 b/app-text/gpdf/files/digest-gpdf-2.10.0
new file mode 100644
index 000000000000..05bc0c9effe5
--- /dev/null
+++ b/app-text/gpdf/files/digest-gpdf-2.10.0
@@ -0,0 +1 @@
+MD5 9278cd3b9d06e3b1d364452f0e512fa9 gpdf-2.10.0.tar.bz2 1079944
diff --git a/app-text/gpdf/gpdf-2.10.0.ebuild b/app-text/gpdf/gpdf-2.10.0.ebuild
new file mode 100644
index 000000000000..140c60a39bc7
--- /dev/null
+++ b/app-text/gpdf/gpdf-2.10.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gpdf/gpdf-2.10.0.ebuild,v 1.14 2005/08/12 16:33:18 mr_bones_ Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Viewer for Portable Document Format (PDF) files"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~ia64 mips ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.5.4
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libbonobo-2.2.1
+ >=gnome-base/libbonoboui-2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/libgnomeprint-2.6
+ >=gnome-base/libgnomeprintui-2.2
+ >=gnome-base/libglade-2"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.29
+ >=dev-util/pkgconfig-0.12.0"
+
+PROVIDE="virtual/pdfviewer"
+
+DOCS="AUTHORS CHANGES ChangeLog NEWS README*"
+
+USE_DESTDIR="1"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # Fix sec vuln (#69662)
+ epatch ${FILESDIR}/${PN}-xpdf_goo_sizet.patch
+ # Fix building on amd64 with gcc4
+ epatch ${FILESDIR}/${P}-amd64-gcc4.patch
+ # Disable the tests, see bug #73882
+ sed -i -e "s:test-files::" Makefile.in
+}
+
+src_install() {
+
+ # fix #92920 FIXME
+ gnome2_src_install scrollkeeper_localstate_dir=${D}/var/lib/scrollkeeper/
+
+}
+