summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2005-06-08 10:52:42 +0000
committerHeinrich Wendel <lanius@gentoo.org>2005-06-08 10:52:42 +0000
commitddc80346304ec2dec1af7a9c1c185d3748a3a1b3 (patch)
tree454d6f539558d9887a13c714d73cc0d04c5be8ae /app-text/gsview
parentversion bump, gcc-3.4 fix. (diff)
downloadgentoo-2-ddc80346304ec2dec1af7a9c1c185d3748a3a1b3.tar.gz
gentoo-2-ddc80346304ec2dec1af7a9c1c185d3748a3a1b3.tar.bz2
gentoo-2-ddc80346304ec2dec1af7a9c1c185d3748a3a1b3.zip
fix docs, bug #95398
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-text/gsview')
-rw-r--r--app-text/gsview/ChangeLog6
-rw-r--r--app-text/gsview/Manifest9
-rwxr-xr-xapp-text/gsview/files/gsview-help23
-rw-r--r--app-text/gsview/gsview-4.6-r1.ebuild8
4 files changed, 37 insertions, 9 deletions
diff --git a/app-text/gsview/ChangeLog b/app-text/gsview/ChangeLog
index 70d0af14a036..725397e85d68 100644
--- a/app-text/gsview/ChangeLog
+++ b/app-text/gsview/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/gsview
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gsview/ChangeLog,v 1.14 2005/06/05 12:02:21 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gsview/ChangeLog,v 1.15 2005/06/08 10:52:42 lanius Exp $
+
+ 08 Jun 2005; Heinrich Wendel <lanius@gentoo.org> +files/gsview-help,
+ gsview-4.6-r1.ebuild:
+ fix docs, bug #95398
05 Jun 2005; Michael Hanselmann <hansmi@gentoo.org> gsview-4.6.ebuild:
Stable on ppc.
diff --git a/app-text/gsview/Manifest b/app-text/gsview/Manifest
index 59dab9655502..57a92772784a 100644
--- a/app-text/gsview/Manifest
+++ b/app-text/gsview/Manifest
@@ -1,6 +1,7 @@
-MD5 1b6702b64639992732a642a11891e764 gsview-4.6-r1.ebuild 1051
-MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
-MD5 089745e69cd2138d2f86af171f997aa9 ChangeLog 1511
MD5 2ec3b1d4b6013e3a5c67f3538b1988b5 gsview-4.6.ebuild 1039
-MD5 43585e75c85371fbcda163c65204c228 files/digest-gsview-4.6-r1 58
+MD5 c65e2da80fc0a142a7b762ebaa13f37b gsview-4.6-r1.ebuild 1102
+MD5 089745e69cd2138d2f86af171f997aa9 ChangeLog 1511
+MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
MD5 43585e75c85371fbcda163c65204c228 files/digest-gsview-4.6 58
+MD5 7473af7f015751a24f38bae02288f54c files/gsview-help 300
+MD5 43585e75c85371fbcda163c65204c228 files/digest-gsview-4.6-r1 58
diff --git a/app-text/gsview/files/gsview-help b/app-text/gsview/files/gsview-help
new file mode 100755
index 000000000000..82ae6d0c5601
--- /dev/null
+++ b/app-text/gsview/files/gsview-help
@@ -0,0 +1,23 @@
+#!/bin/sh
+
+if [ -z "$1" ]
+then
+ echo "Usage: $0 URL [TAG]"
+ echo " URL: The URL to open"
+ echo " TAG: The anchor at that url"
+ exit 1
+fi
+
+if [ -z "$2" ]
+then
+ TAG=''
+else
+ TAG="#$2"
+fi
+
+if mozilla -remote openFile\(file://$1$TAG\) ; then
+ exit 0
+else
+ mozilla file://$1$TAG
+fi
+exit 0
diff --git a/app-text/gsview/gsview-4.6-r1.ebuild b/app-text/gsview/gsview-4.6-r1.ebuild
index f25a1fca1b0a..1b8218327e5b 100644
--- a/app-text/gsview/gsview-4.6-r1.ebuild
+++ b/app-text/gsview/gsview-4.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gsview/gsview-4.6-r1.ebuild,v 1.1 2005/06/01 00:01:06 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gsview/gsview-4.6-r1.ebuild,v 1.2 2005/06/08 10:52:42 lanius Exp $
MY_PV="${PV/.}"
DESCRIPTION="gsView PostScript and PDF viewer"
@@ -22,7 +22,9 @@ src_compile() {
ln -s srcunx/unx.mak Makefile
## respect CFLAGS
+ echo ${P}
sed -i -e "s:^CFLAGS=-O :CFLAGS=${CFLAGS} :g" Makefile
+ sed -i -e "s:GSVIEW_DOCPATH:\"/usr/share/doc/${PF}/html/\":" srcunx/gvx.c
## run Makefile
make || die "Error compiling files."
@@ -31,15 +33,13 @@ src_compile() {
src_install() {
dobin bin/gsview
- insinto /usr/share/applications
- newins srcunx/gvxhelp.txt gview
-
doman srcunx/gsview.1
dodoc gsview.css cdorder.txt regorder.txt LICENCE
if use doc
then
+ dobin ${FILESDIR}/gsview-help
dohtml *.htm bin/*.htm
fi