summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-08 14:03:34 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-08 14:03:34 +0000
commitb640f7523bf841dd9b31b5e9c7e3ee1f1c80bfe1 (patch)
tree22d141c43bbae24b5ce45d9c38d829c71a669c3e /app-text/gv
parentFHS compliance (diff)
downloadgentoo-2-b640f7523bf841dd9b31b5e9c7e3ee1f1c80bfe1.tar.gz
gentoo-2-b640f7523bf841dd9b31b5e9c7e3ee1f1c80bfe1.tar.bz2
gentoo-2-b640f7523bf841dd9b31b5e9c7e3ee1f1c80bfe1.zip
FHS compliancy
Diffstat (limited to 'app-text/gv')
-rw-r--r--app-text/gv/ChangeLog6
-rw-r--r--app-text/gv/gv-3.5.8-r1.ebuild88
2 files changed, 43 insertions, 51 deletions
diff --git a/app-text/gv/ChangeLog b/app-text/gv/ChangeLog
index 24b656cc4e87..bb8dd8283a3d 100644
--- a/app-text/gv/ChangeLog
+++ b/app-text/gv/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for app-text/gv
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/gv/ChangeLog,v 1.3 2002/08/02 17:42:49 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gv/ChangeLog,v 1.4 2002/08/08 14:03:34 seemant Exp $
*gv-3.5.8-r1 (1 Feb 2002)
+ 08 Aug 2002; Seemant Kulleen <semant@gentoo.org> gv-3.5.8-r1.ebuild :
+
+ Made more FHS Compliant.
+
2 Aug 2002; phoen][x <phoenix@gentoo.org> gv-3.5.8-r1.ebuild :
Added LICENSE, SLOT.
diff --git a/app-text/gv/gv-3.5.8-r1.ebuild b/app-text/gv/gv-3.5.8-r1.ebuild
index 7a0684388a18..f1d41e2cf0b1 100644
--- a/app-text/gv/gv-3.5.8-r1.ebuild
+++ b/app-text/gv/gv-3.5.8-r1.ebuild
@@ -1,74 +1,62 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-text/gv/gv-3.5.8-r1.ebuild,v 1.8 2002/08/02 17:42:49 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gv/gv-3.5.8-r1.ebuild,v 1.9 2002/08/08 14:03:34 seemant Exp $
# this r1 is a major change. it uses sed instead of patches.
# hopefully this will enable everyone to compile gv on widely
# different configurations, eliminating the gv.man/gv._man problem
S=${WORKDIR}/${P}
-
DESCRIPTION="gv is a standard ghostscript frontend used e.g. by LyX"
-
SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/gv/unix/${P}.tar.gz"
HOMEPAGE="http://wwwthep.physik.uni-mainz.de/~plass/gv/"
+
SLOT="0"
LICENSE="GPL-2"
+KEYWORDS="ppc x86"
# There's probably more, but ghostscript also depends on it,
# so I can't identify it
-DEPEND="virtual/x11 x11-libs/Xaw3d app-text/ghostscript"
-KEYWORDS="ppc x86"
-src_unpack() {
-
- # need to check if this can be done automatically
-
- unpack ${P}.tar.gz
- cd ${S}
-
-}
+DEPEND="virtual/x11
+ x11-libs/Xaw3d
+ app-text/ghostscript"
src_compile() {
-
- cd ${S}
-
- cp config.Unix 1
- sed -e 's/usr\/local/usr/' 1 > config.Unix
- rm 1
-
- try xmkmf
- try make Makefiles
-
- cd source
-
- cp Makefile 1
- cat 1 | sed -e 's/install.man:: gv.man/install.man::/' \
+
+ cp config.Unix 1
+ sed -e 's:usr/local:usr:' 1 > config.Unix
+ rm 1
+
+ xmkmf || die
+ make Makefiles || die
+
+ cd source
+
+ cp Makefile 1
+ cat 1 | sed -e 's/install.man:: gv.man/install.man::/' \
-e 's/all:: gv./\#all:: gv./' \
-e '/gv.man/ c \#removed by sed for ebuilding' > Makefile
- rm 1
- if [ ! "`grep gv.man Makefile`" = "" ];
- then
- echo "sed didn't completely remove gv.man references from the Makefile.
-We'll just run make and pray."
- sleep 2s
- fi
-
-
- cd ${S}
- try emake
-
+ rm 1
+ if [ ! "`grep gv.man Makefile`" = "" ];
+ then
+ echo "sed didn't completely remove gv.man references from the Makefile."
+ echo "We'll just run make and pray."
+ sleep 2s
+ fi
+
+
+ cd ${S}
+ emake || die
}
src_install () {
-
- cd ${S}
- try make DESTDIR=${D} install
- # try make DESTDIR=${D} install.man # don't use this!!!
- try make DESTDIR=${D} install.doc
-
- cd ${S}/doc
- cp gv.man gv.man.1
- doman gv.man.1
-
+
+ cd ${S}
+ make DESTDIR=${D} install || die
+ # make DESTDIR=${D} install.man || die # don't use this!!!
+ make GV_DOCDIR=${D}/usr/share/doc/${PF} install.doc || die
+
+ cd ${S}/doc
+ cp gv.man gv.man.1
+ doman gv.man.1
}
-