summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-04 17:25:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-04 17:25:55 +0000
commitd9fbd132186d74e70f141ea5143532140303c011 (patch)
tree56133c90082a136e5b9625af1234a20aa6991135 /app-text/gv
parentFix comment (diff)
downloadgentoo-2-d9fbd132186d74e70f141ea5143532140303c011.tar.gz
gentoo-2-d9fbd132186d74e70f141ea5143532140303c011.tar.bz2
gentoo-2-d9fbd132186d74e70f141ea5143532140303c011.zip
Bump to 3.6.6. Fixes #237507. Thanks to Colin MacDonald for a small patch.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-text/gv')
-rw-r--r--app-text/gv/ChangeLog9
-rw-r--r--app-text/gv/gv-3.6.6.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/app-text/gv/ChangeLog b/app-text/gv/ChangeLog
index 2211ca606ae2..b0a2faae7eee 100644
--- a/app-text/gv/ChangeLog
+++ b/app-text/gv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/gv
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gv/ChangeLog,v 1.76 2008/06/21 07:29:23 drac Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gv/ChangeLog,v 1.77 2009/02/04 17:25:55 patrick Exp $
+
+*gv-3.6.6 (04 Feb 2009)
+
+ 04 Feb 2009; Patrick Lauer <patrick@gentoo.org> +gv-3.6.6.ebuild:
+ Bump to 3.6.6. Fixes #237507. Thanks to Colin MacDonald for a small patch.
*gv-3.6.4 (21 Jun 2008)
diff --git a/app-text/gv/gv-3.6.6.ebuild b/app-text/gv/gv-3.6.6.ebuild
new file mode 100644
index 000000000000..a52926abdb3b
--- /dev/null
+++ b/app-text/gv/gv-3.6.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gv/gv-3.6.6.ebuild,v 1.1 2009/02/04 17:25:55 patrick Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="gv is used to view PostScript and PDF documents using Ghostscript"
+HOMEPAGE="http://www.gnu.org/software/gv/"
+SRC_URI="mirror://gnu/gv/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/Xaw3d
+ virtual/ghostscript
+ x11-libs/libXt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/gv-3.6.1-a0.patch
+
+ # Make font render nicely even with gs-8, bug 135354
+ sed -i \
+ -e "s:-dGraphicsAlphaBits=2:\0 -dAlignToPixels=0:" \
+ src/Makefile.am || die "sed failed."
+
+ eautoreconf
+}
+
+src_compile() {
+ econf --disable-dependency-tracking \
+ --enable-scrollbar-code || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ doicon src/gv_icon.xbm
+ make_desktop_entry gv "GhostView" /usr/share/pixmaps/gv_icon.xbm "Graphics;Viewer;"
+ dodoc AUTHORS ChangeLog README
+}