summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2003-10-26 05:58:20 +0000
committerMike Gardiner <obz@gentoo.org>2003-10-26 05:58:20 +0000
commita9999341ebd06e5961af29259107b56583af52c9 (patch)
tree26a2a4e4fadb0f079a96d33cbe0f2741c0bc4fe5 /app-text/html2text/html2text-1.3.1.ebuild
parentbump -r1 to stable (diff)
downloadgentoo-2-a9999341ebd06e5961af29259107b56583af52c9.tar.gz
gentoo-2-a9999341ebd06e5961af29259107b56583af52c9.tar.bz2
gentoo-2-a9999341ebd06e5961af29259107b56583af52c9.zip
Added gcc-3.3 patch
Diffstat (limited to 'app-text/html2text/html2text-1.3.1.ebuild')
-rw-r--r--app-text/html2text/html2text-1.3.1.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/app-text/html2text/html2text-1.3.1.ebuild b/app-text/html2text/html2text-1.3.1.ebuild
index e63d8dfe53b8..387310c22791 100644
--- a/app-text/html2text/html2text-1.3.1.ebuild
+++ b/app-text/html2text/html2text-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/html2text/html2text-1.3.1.ebuild,v 1.2 2003/09/30 13:28:24 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/html2text/html2text-1.3.1.ebuild,v 1.3 2003/10/26 05:57:54 obz Exp $
DESCRIPTION="A HTML to text converter"
SRC_URI="http://userpage.fu-berlin.de/~mbayer/tools/${P}.tar.gz"
@@ -13,6 +13,17 @@ IUSE=""
DEPEND="virtual/glibc"
+src_unpack() {
+
+ unpack ${A}
+ # apply a patch for g++ 3.3, provided by the html2text
+ # people (see homepage) <obz@gentoo.org>
+ if has_version ">=sys-devel/gcc-3.3*"; then
+ epatch ${FILESDIR}/${PN}-gcc3.3.patch
+ fi
+
+}
+
src_compile() {
./configure || die
emake || die