summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin F. Quinn <kevquinn@gentoo.org>2006-08-30 21:38:11 +0000
committerKevin F. Quinn <kevquinn@gentoo.org>2006-08-30 21:38:11 +0000
commit219635b5233a29dfb79a3af34dd9deb9c0e0c7cc (patch)
treee35dca48809aeba11702749e2eedde28682c53c2 /app-text/hunspell
parentversion bump (diff)
downloadgentoo-2-219635b5233a29dfb79a3af34dd9deb9c0e0c7cc.tar.gz
gentoo-2-219635b5233a29dfb79a3af34dd9deb9c0e0c7cc.tar.bz2
gentoo-2-219635b5233a29dfb79a3af34dd9deb9c0e0c7cc.zip
Add nls USE flag and activate configure option (thanks Flameeyes).
(Portage version: 2.1.1_rc1-r1)
Diffstat (limited to 'app-text/hunspell')
-rw-r--r--app-text/hunspell/ChangeLog9
-rw-r--r--app-text/hunspell/files/digest-hunspell-1.1.4-r23
-rw-r--r--app-text/hunspell/hunspell-1.1.4-r2.ebuild79
3 files changed, 90 insertions, 1 deletions
diff --git a/app-text/hunspell/ChangeLog b/app-text/hunspell/ChangeLog
index f1b07fcf9546..830255464485 100644
--- a/app-text/hunspell/ChangeLog
+++ b/app-text/hunspell/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/hunspell
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/ChangeLog,v 1.19 2006/08/08 02:07:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/ChangeLog,v 1.20 2006/08/30 21:38:11 kevquinn Exp $
+
+*hunspell-1.1.4-r2 (30 Aug 2006)
+
+ 30 Aug 2006; Kevin F. Quinn <kevquinn@gentoo.org>
+ +hunspell-1.1.4-r2.ebuild:
+ Add nls USE flag and activate configure option (thanks Flameeyes). Also skip
+ installation of internal header files.
08 Aug 2006; Mike Frysinger <vapier@gentoo.org>
+files/hunspell-1.1.4-gettext.patch, hunspell-1.1.4-r1.ebuild:
diff --git a/app-text/hunspell/files/digest-hunspell-1.1.4-r2 b/app-text/hunspell/files/digest-hunspell-1.1.4-r2
new file mode 100644
index 000000000000..1bd701b1a28f
--- /dev/null
+++ b/app-text/hunspell/files/digest-hunspell-1.1.4-r2
@@ -0,0 +1,3 @@
+MD5 4cf2dfb89dd58392ad5a1183c69eb628 hunspell-1.1.4.tar.gz 438667
+RMD160 a90ded6b996d8b2d575268e8a4b025e92b85f378 hunspell-1.1.4.tar.gz 438667
+SHA256 8d39c03beb71ec1482d2fdbfc2d5b7690c8a70fb6da4885369752ee0d2e3a635 hunspell-1.1.4.tar.gz 438667
diff --git a/app-text/hunspell/hunspell-1.1.4-r2.ebuild b/app-text/hunspell/hunspell-1.1.4-r2.ebuild
new file mode 100644
index 000000000000..594b68ba4cc8
--- /dev/null
+++ b/app-text/hunspell/hunspell-1.1.4-r2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/hunspell-1.1.4-r2.ebuild,v 1.1 2006/08/30 21:38:11 kevquinn Exp $
+
+inherit fixheadtails eutils multilib autotools
+
+DESCRIPTION="Hunspell spell checker - an improved replacement for myspell in OOo"
+HOMEPAGE="http://hunspell.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+IUSE="ncurses nls readline"
+
+RDEPEND="readline? ( sys-libs/readline )
+ ncurses? ( sys-libs/ncurses )
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ht_fix_file tests/test.sh
+ # Rework to use libtool, so as to get shared libraries
+ # where appropriate, instead of the archive-only approach
+ # taken upstream.
+ epatch "${FILESDIR}"/${P}-libtool.patch
+ # Upstream package creates executables 'example', 'munch'
+ # and 'unmunch' which are too generic to be placed in
+ # /usr/bin - this patch prefixes them with 'hunspell-'.
+ # Also includes a small change for libtool.
+ epatch "${FILESDIR}"/${P}-renameexes.patch
+ # Don't install the munch.h and unmunch.h files, they are not
+ # descriptions of exported functions.
+ sed -i -e 's:include_HEADERS:noinst_HEADERS:' "${S}"/src/tools/Makefile.am
+
+ # Recalculate the mkinstalldirs stuff (see bug #142565)
+ epatch "${FILESDIR}"/${P}-gettext.patch
+ # Set AT_M4DIR to workaround eautoreconf limitation (see bug #142565)
+ export AT_M4DIR="${S}/m4"
+ # Makefile.am modified, libtool added, hence autoreconf
+ WANT_AUTOMAKE="1.9" eautoreconf
+}
+
+src_compile() {
+ # I wanted to put the include files in /usr/include/hunspell
+ # but this means the openoffice build won't find them.
+ econf \
+ --includedir=/usr/include/hunspell \
+ $(use_enable readline) \
+ $(use_with ncurses ui) \
+ $(use_enable nls) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_test() {
+ # One of the tests doesn't like LC_ALL being set to encodings
+ # capable of expressing beta-S, so we simply clear it.
+ # bug #125375
+ LC_ALL="C" make check
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ # hunspell is derived from myspell
+ dodoc AUTHORS.myspell README.myspell license.myspell
+}
+
+pkg_postinst() {
+ einfo "To use this package you will also need a dictionary."
+ einfo "Hunspell uses myspell format dictionaries; find them"
+ einfo "in the app-dicts category as myspell-<LANG>."
+}