summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-12 18:11:17 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-12 18:11:17 +0000
commit1cfb3afe2900b752e7ece5027c20f8ef7837695c (patch)
treecc6d026af9e1cd17480f0b447c409cde70f8ad77 /app-text/jing/jing-20030619-r1.ebuild
parentStable ... (diff)
downloadgentoo-2-1cfb3afe2900b752e7ece5027c20f8ef7837695c.tar.gz
gentoo-2-1cfb3afe2900b752e7ece5027c20f8ef7837695c.tar.bz2
gentoo-2-1cfb3afe2900b752e7ece5027c20f8ef7837695c.zip
Style/Dep fixes
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-text/jing/jing-20030619-r1.ebuild')
-rw-r--r--app-text/jing/jing-20030619-r1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/app-text/jing/jing-20030619-r1.ebuild b/app-text/jing/jing-20030619-r1.ebuild
index 80ac67e7d3b4..7e0308dab30e 100644
--- a/app-text/jing/jing-20030619-r1.ebuild
+++ b/app-text/jing/jing-20030619-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/jing/jing-20030619-r1.ebuild,v 1.5 2005/05/12 21:45:48 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/jing/jing-20030619-r1.ebuild,v 1.6 2005/07/12 18:11:17 axxo Exp $
inherit java-pkg eutils
@@ -11,20 +11,21 @@ LICENSE="BSD Apache-1.1"
SLOT="0"
KEYWORDS="x86 amd64 ~ppc"
IUSE="jikes doc"
-DEPEND=">=virtual/jdk-1.3
- jikes? ( >=dev-java/jikes-1.21 )
- app-arch/unzip"
RDEPEND=">=virtual/jre-1.3
=dev-java/saxon-bin-8*
=dev-java/xerces-1.3*
dev-java/iso-relax"
+DEPEND=">=virtual/jdk-1.3
+ ${RDEPEND}
+ jikes? ( >=dev-java/jikes-1.21 )
+ app-arch/unzip"
src_unpack() {
unpack ${A}
cd ${S}
mkdir src/
- unzip -qq -d src/ src.zip
+ unzip -qq -d src/ src.zip || die "failed to unzip"
cd src/
epatch ${FILESDIR}/build-patch.diff
@@ -42,7 +43,7 @@ src_unpack() {
src_compile() {
antflags="jar"
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
- ant ${antflags}
+ ant ${antflags} || die "failed to build"
}
src_install() {