summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-09-20 14:32:34 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-09-20 14:32:34 +0000
commit4850b229dc8fdb4777249c5bcf81b7e95f0fc1d7 (patch)
tree361f5e4aacf83ebad6e7da5a78f3b1247db1f0df /app-text/libmspub
parentStable for x86, wrt bug #429196 (diff)
downloadgentoo-2-4850b229dc8fdb4777249c5bcf81b7e95f0fc1d7.tar.gz
gentoo-2-4850b229dc8fdb4777249c5bcf81b7e95f0fc1d7.tar.bz2
gentoo-2-4850b229dc8fdb4777249c5bcf81b7e95f0fc1d7.zip
Add release.
(Portage version: 2.2.0_alpha128/cvs/Linux x86_64)
Diffstat (limited to 'app-text/libmspub')
-rw-r--r--app-text/libmspub/ChangeLog8
-rw-r--r--app-text/libmspub/libmspub-0.0.3.ebuild48
2 files changed, 54 insertions, 2 deletions
diff --git a/app-text/libmspub/ChangeLog b/app-text/libmspub/ChangeLog
index 3128e4655158..ab9ce1fc7396 100644
--- a/app-text/libmspub/ChangeLog
+++ b/app-text/libmspub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/libmspub
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libmspub/ChangeLog,v 1.1 2012/06/07 11:41:17 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libmspub/ChangeLog,v 1.2 2012/09/20 14:32:34 scarabeus Exp $
+
+*libmspub-0.0.3 (20 Sep 2012)
+
+ 20 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org> +libmspub-0.0.3.ebuild:
+ Add release.
*libmspub-9999 (07 Jun 2012)
@@ -8,4 +13,3 @@
+metadata.xml:
Initial commit, live ebuild for now. Required by trunk libreoffice. Fixes
bug#419967.
-
diff --git a/app-text/libmspub/libmspub-0.0.3.ebuild b/app-text/libmspub/libmspub-0.0.3.ebuild
new file mode 100644
index 000000000000..0e3fcf3f97cd
--- /dev/null
+++ b/app-text/libmspub/libmspub-0.0.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libmspub/libmspub-0.0.3.ebuild,v 1.1 2012/09/20 14:32:34 scarabeus Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/${PN}/"
+[[ ${PV} == 9999 ]] && vcs="autotools git-2"
+inherit base ${vcs}
+unset vcs
+
+DESCRIPTION="Library parsing the Microsoft Publisher documents"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libmspub"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+[[ ${PV} == 9999 ]] || KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ app-text/libwpd:0.9
+ app-text/libwpg:0.2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/libtool
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ base_src_prepare
+ [[ -d m4 ]] || mkdir "m4"
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-werror \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}