summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-09-13 20:13:19 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-09-13 20:13:19 +0000
commit094abe70e60826199b95170b347d38c87e51bdc6 (patch)
treed229cfe50d056a07480c1bb5104a9ed4d3ad7fa8 /app-text/libmwaw
parentbump version to 1.0.4 (diff)
downloadgentoo-2-094abe70e60826199b95170b347d38c87e51bdc6.tar.gz
gentoo-2-094abe70e60826199b95170b347d38c87e51bdc6.tar.bz2
gentoo-2-094abe70e60826199b95170b347d38c87e51bdc6.zip
Version bump. Thanks to Andreas Sturmlechner.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'app-text/libmwaw')
-rw-r--r--app-text/libmwaw/ChangeLog7
-rw-r--r--app-text/libmwaw/libmwaw-0.3.1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/app-text/libmwaw/ChangeLog b/app-text/libmwaw/ChangeLog
index 9ba34fd9aea6..04a4b0e284c4 100644
--- a/app-text/libmwaw/ChangeLog
+++ b/app-text/libmwaw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/libmwaw
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libmwaw/ChangeLog,v 1.12 2014/06/29 16:43:43 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libmwaw/ChangeLog,v 1.13 2014/09/13 20:13:19 dilfridge Exp $
+
+*libmwaw-0.3.1 (13 Sep 2014)
+
+ 13 Sep 2014; Andreas K. Huettel <dilfridge@gentoo.org> +libmwaw-0.3.1.ebuild:
+ Version bump. Thanks to Andreas Sturmlechner.
29 Jun 2014; Agostino Sarubbo <ago@gentoo.org> libmwaw-0.2.0.ebuild:
Stable for x86, wrt bug #514886
diff --git a/app-text/libmwaw/libmwaw-0.3.1.ebuild b/app-text/libmwaw/libmwaw-0.3.1.ebuild
new file mode 100644
index 000000000000..a455e1c30a72
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libmwaw/libmwaw-0.3.1.ebuild,v 1.1 2014/09/13 20:13:19 dilfridge Exp $
+
+EAPI=5
+
+inherit base eutils
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="http://sourceforge.net/p/libmwaw/wiki/Home/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46:=
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --with-sharedptr=boost \
+ --enable-zip \
+ --disable-werror \
+ $(use_enable static-libs static) \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}