summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-06-11 20:10:51 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-06-11 20:10:51 +0000
commitefba9bca36b1d6cd9cbd8822f1d4dc416c276c44 (patch)
treeea43d34b3d82ed0e7a00176c55e155b13d9fbc47 /app-text/mftrace
parentRemoving myself as maintainer (diff)
downloadgentoo-2-efba9bca36b1d6cd9cbd8822f1d4dc416c276c44.tar.gz
gentoo-2-efba9bca36b1d6cd9cbd8822f1d4dc416c276c44.tar.bz2
gentoo-2-efba9bca36b1d6cd9cbd8822f1d4dc416c276c44.zip
version bump, bug #316279
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-text/mftrace')
-rw-r--r--app-text/mftrace/ChangeLog7
-rw-r--r--app-text/mftrace/mftrace-1.2.16.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/app-text/mftrace/ChangeLog b/app-text/mftrace/ChangeLog
index d00305ef0cb1..d71e5dc5692b 100644
--- a/app-text/mftrace/ChangeLog
+++ b/app-text/mftrace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/mftrace
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mftrace/ChangeLog,v 1.55 2010/06/11 20:04:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mftrace/ChangeLog,v 1.56 2010/06/11 20:10:51 aballier Exp $
+
+*mftrace-1.2.16 (11 Jun 2010)
+
+ 11 Jun 2010; Alexis Ballier <aballier@gentoo.org> +mftrace-1.2.16.ebuild:
+ version bump, bug #316279
11 Jun 2010; Alexis Ballier <aballier@gentoo.org> mftrace-1.2.13.ebuild,
mftrace-1.2.13-r1.ebuild:
diff --git a/app-text/mftrace/mftrace-1.2.16.ebuild b/app-text/mftrace/mftrace-1.2.16.ebuild
new file mode 100644
index 000000000000..b2d67b206973
--- /dev/null
+++ b/app-text/mftrace/mftrace-1.2.16.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mftrace/mftrace-1.2.16.ebuild,v 1.1 2010/06/11 20:10:51 aballier Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit python multilib toolchain-funcs
+
+DESCRIPTION="Traces TeX fonts to PFA or PFB fonts (formerly pktrace)"
+HOMEPAGE="http://lilypond.org/mftrace/"
+SRC_URI="http://lilypond.org/download/sources/mftrace/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+# SLOT 1 was used in pktrace ebuild
+SLOT="1"
+IUSE="truetype"
+
+DEPEND="|| ( media-gfx/potrace >=media-gfx/autotrace-0.30 )"
+RDEPEND="${DEPEND}
+ virtual/latex-base
+ >=app-text/t1utils-1.25
+ truetype? ( media-gfx/fontforge )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ tc-export CC
+ econf --datadir=$(python_get_sitedir)
+}
+
+src_compile() {
+ emake CFLAGS="-Wall ${CFLAGS}" || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" PYC_MODULES="" install || die "make install failed"
+ dodoc README.txt ChangeLog
+}
+
+pkg_postinst() {
+ python_mod_optimize mftrace
+}
+
+pkg_postrm() {
+ python_mod_cleanup mftrace
+}