summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-03-18 14:55:35 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-03-18 14:55:35 +0000
commit5e96780c921050b999563185864a8a953f77240b (patch)
treeb007a48eb179fe3f7f9316e28960fa868e023e9e /app-text/namazu
parentalpha/ia64 stable wrt #260063 (diff)
downloadgentoo-2-5e96780c921050b999563185864a8a953f77240b.tar.gz
gentoo-2-5e96780c921050b999563185864a8a953f77240b.tar.bz2
gentoo-2-5e96780c921050b999563185864a8a953f77240b.zip
Fixed tk USE flag issue, bug #262662.
(Portage version: 2.1.6.8/cvs/Linux x86_64)
Diffstat (limited to 'app-text/namazu')
-rw-r--r--app-text/namazu/ChangeLog7
-rw-r--r--app-text/namazu/namazu-2.0.19-r1.ebuild83
2 files changed, 89 insertions, 1 deletions
diff --git a/app-text/namazu/ChangeLog b/app-text/namazu/ChangeLog
index 939767dd4f36..0b89062e44b8 100644
--- a/app-text/namazu/ChangeLog
+++ b/app-text/namazu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/namazu
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/namazu/ChangeLog,v 1.32 2009/03/12 16:44:46 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/namazu/ChangeLog,v 1.33 2009/03/18 14:55:35 matsuu Exp $
+
+*namazu-2.0.19-r1 (18 Mar 2009)
+
+ 18 Mar 2009; MATSUU Takuto <matsuu@gentoo.org> +namazu-2.0.19-r1.ebuild:
+ Fixed tk USE flag issue, bug #262662.
*namazu-2.0.19 (12 Mar 2009)
diff --git a/app-text/namazu/namazu-2.0.19-r1.ebuild b/app-text/namazu/namazu-2.0.19-r1.ebuild
new file mode 100644
index 000000000000..df2ccf06f357
--- /dev/null
+++ b/app-text/namazu/namazu-2.0.19-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/namazu/namazu-2.0.19-r1.ebuild,v 1.1 2009/03/18 14:55:35 matsuu Exp $
+
+inherit eutils elisp-common
+
+IUSE="emacs nls tk linguas_ja"
+
+DESCRIPTION="Namazu is a full-text search engine"
+HOMEPAGE="http://www.namazu.org/"
+SRC_URI="http://www.namazu.org/stable/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND=">=dev-perl/File-MMagic-1.20
+ emacs? ( virtual/emacs )
+ linguas_ja? (
+ app-i18n/nkf
+ || (
+ dev-perl/Text-Kakasi
+ app-i18n/kakasi
+ app-text/chasen
+ app-text/mecab
+ )
+ )
+ nls? ( virtual/libintl )
+ tk? (
+ dev-lang/tk
+ www-client/lynx
+ )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_compile() {
+ local myconf
+
+ use tk && myconf="--with-namazu=/usr/bin/namazu
+ --with-mknmz=/usr/bin/mknmz
+ --with-indexdir=/var/lib/namazu/index"
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable tk tknamazu) \
+ ${myconf} || die
+ emake || die
+
+ if use emacs; then
+ cd lisp
+ elisp-compile gnus-nmz-1.el namazu.el || die
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS CREDITS ChangeLog* HACKING* NEWS README* THANKS TODO etc/*.png
+ dohtml -r doc/*
+
+ if use emacs; then
+ elisp-install ${PN} lisp/gnus-nmz-1.el* lisp/namazu.el* || die
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el || die
+
+ docinto lisp
+ dodoc lisp/ChangeLog*
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}