summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-09-24 13:40:15 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-09-24 13:40:15 +0000
commit83bb5b3dfbbf0d7f426f374d6db6135482bc338c (patch)
tree2fc4c67f6dfaf20593a4e28dc35c69d538182a06 /app-text/namazu
parentMask xfdesktop-4.6.1-r1 temporarily because there's issues with icon position... (diff)
downloadgentoo-2-83bb5b3dfbbf0d7f426f374d6db6135482bc338c.tar.gz
gentoo-2-83bb5b3dfbbf0d7f426f374d6db6135482bc338c.tar.bz2
gentoo-2-83bb5b3dfbbf0d7f426f374d6db6135482bc338c.zip
Version bumped.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-text/namazu')
-rw-r--r--app-text/namazu/ChangeLog7
-rw-r--r--app-text/namazu/namazu-2.0.20.ebuild83
2 files changed, 89 insertions, 1 deletions
diff --git a/app-text/namazu/ChangeLog b/app-text/namazu/ChangeLog
index 0b89062e44b8..10c946c74198 100644
--- a/app-text/namazu/ChangeLog
+++ b/app-text/namazu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/namazu
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/namazu/ChangeLog,v 1.33 2009/03/18 14:55:35 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/namazu/ChangeLog,v 1.34 2009/09/24 13:40:15 matsuu Exp $
+
+*namazu-2.0.20 (24 Sep 2009)
+
+ 24 Sep 2009; MATSUU Takuto <matsuu@gentoo.org> +namazu-2.0.20.ebuild:
+ Version bumped.
*namazu-2.0.19-r1 (18 Mar 2009)
diff --git a/app-text/namazu/namazu-2.0.20.ebuild b/app-text/namazu/namazu-2.0.20.ebuild
new file mode 100644
index 000000000000..c146ca57d37c
--- /dev/null
+++ b/app-text/namazu/namazu-2.0.20.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/namazu/namazu-2.0.20.ebuild,v 1.1 2009/09/24 13:40:15 matsuu Exp $
+
+inherit eutils elisp-common
+
+IUSE="emacs nls tk linguas_ja"
+
+DESCRIPTION="Namazu is a full-text search engine"
+HOMEPAGE="http://www.namazu.org/"
+SRC_URI="http://www.namazu.org/stable/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND=">=dev-perl/File-MMagic-1.20
+ emacs? ( virtual/emacs )
+ linguas_ja? (
+ app-i18n/nkf
+ || (
+ dev-perl/Text-Kakasi
+ app-i18n/kakasi
+ app-text/chasen
+ app-text/mecab
+ )
+ )
+ nls? ( virtual/libintl )
+ tk? (
+ dev-lang/tk
+ www-client/lynx
+ )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-2.0.19-gentoo.patch"
+}
+
+src_compile() {
+ local myconf
+
+ use tk && myconf="--with-namazu=/usr/bin/namazu
+ --with-mknmz=/usr/bin/mknmz
+ --with-indexdir=/var/lib/namazu/index"
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable tk tknamazu) \
+ ${myconf} || die
+ emake || die
+
+ if use emacs; then
+ cd lisp
+ elisp-compile gnus-nmz-1.el namazu.el || die
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS CREDITS ChangeLog* HACKING* NEWS README* THANKS TODO etc/*.png
+ dohtml -r doc/*
+
+ if use emacs; then
+ elisp-install ${PN} lisp/gnus-nmz-1.el* lisp/namazu.el* || die
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el || die
+
+ docinto lisp
+ dodoc lisp/ChangeLog*
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}