summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-06-24 20:02:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-06-24 20:02:13 +0000
commit0486069cf8a11df622c233635b54876b9fac9c42 (patch)
tree728d2f196a841d0c52180090157ba0817219021c /app-text/opensp/opensp-1.5.2-r2.ebuild
parentMask mail-client/exmh since it depends on mail-client/nmh (diff)
downloadgentoo-2-0486069cf8a11df622c233635b54876b9fac9c42.tar.gz
gentoo-2-0486069cf8a11df622c233635b54876b9fac9c42.tar.bz2
gentoo-2-0486069cf8a11df622c233635b54876b9fac9c42.zip
EAPI=2; add static-libs support; tidy
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'app-text/opensp/opensp-1.5.2-r2.ebuild')
-rw-r--r--app-text/opensp/opensp-1.5.2-r2.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/app-text/opensp/opensp-1.5.2-r2.ebuild b/app-text/opensp/opensp-1.5.2-r2.ebuild
new file mode 100644
index 000000000000..0318456cf0d8
--- /dev/null
+++ b/app-text/opensp/opensp-1.5.2-r2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/opensp/opensp-1.5.2-r2.ebuild,v 1.1 2010/06/24 20:02:13 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils flag-o-matic
+
+MY_P=${P/opensp/OpenSP}
+DESCRIPTION="A free, object-oriented toolkit for SGML parsing and entity management"
+HOMEPAGE="http://openjade.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openjade/${MY_P}.tar.gz"
+
+LICENSE="JamesClark"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="doc nls static-libs"
+
+DEPEND="nls? ( >=sys-devel/gettext-0.14.5 )
+ doc? (
+ app-text/xmlto
+ ~app-text/docbook-xml-dtd-4.1.2
+ )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.5-gcc34.patch
+}
+
+src_configure() {
+ #
+ # The following filters are taken from openjade's ebuild. See bug #100828.
+ #
+
+ # Please note! Opts are disabled. If you know what you're doing
+ # feel free to remove this line. It may cause problems with
+ # docbook-sgml-utils among other things.
+ ALLOWED_FLAGS="-O -O1 -O2 -pipe -g -march"
+ strip-flags
+
+ # Default CFLAGS and CXXFLAGS is -O2 but this make openjade segfault
+ # on hppa. Using -O1 works fine. So I force it here.
+ use hppa && replace-flags -O2 -O1
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-http \
+ --enable-default-catalog=/etc/sgml/catalog \
+ --enable-default-search-path=/usr/share/sgml \
+ --datadir=/usr/share/sgml/${P} \
+ $(use_enable nls) \
+ $(use_enable doc doc-build) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake pkgdocdir=/usr/share/doc/${PF} || die "Compilation failed"
+}
+
+src_test() {
+ echo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ einfo "Skipping tests known not to work"
+ make SHOWSTOPPERS= check || die "Make test failed"
+ SANDBOX_PREDICT="${SANDBOX_PREDICT%:/}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ pkgdocdir=/usr/share/doc/${PF} install || die "Installation failed"
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "Please note that the soname of the library changed."
+ ewarn "If you are upgrading from a previous version you need"
+ ewarn "to fix dynamic linking inconsistencies by executing:"
+ ewarn
+ ewarn " revdep-rebuild --library='libosp.so.*'"
+}