summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-08-18 23:08:09 +0000
committerMarinus Schraal <foser@gentoo.org>2003-08-18 23:08:09 +0000
commit686f494c13d27d8ad33b0c8d96460861c470ffdc (patch)
tree46f98361eeec2dbd88a631ef713c9d0e23e431fc /app-text/ots/ots-0.4.1.ebuild
parentnew version, fixed deps (diff)
downloadgentoo-2-686f494c13d27d8ad33b0c8d96460861c470ffdc.tar.gz
gentoo-2-686f494c13d27d8ad33b0c8d96460861c470ffdc.tar.bz2
gentoo-2-686f494c13d27d8ad33b0c8d96460861c470ffdc.zip
new version, fixed deps
Diffstat (limited to 'app-text/ots/ots-0.4.1.ebuild')
-rw-r--r--app-text/ots/ots-0.4.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/ots/ots-0.4.1.ebuild b/app-text/ots/ots-0.4.1.ebuild
new file mode 100644
index 000000000000..ac04b34cc2cb
--- /dev/null
+++ b/app-text/ots/ots-0.4.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ots/ots-0.4.1.ebuild,v 1.1 2003/08/18 23:07:58 foser Exp $
+
+IUSE="doc"
+
+DESCRIPTION="Open source Text Summarizer, as used in newer releases of abiword and kword."
+HOMEPAGE="http://libots.sourcefourge.net/"
+SRC_URI="mirror://sourceforge/libots/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm"
+
+
+RDEPEND="=dev-libs/glib-2*
+ >=dev-libs/libxml2-2.4.23
+ >=dev-libs/popt-1.5"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+src_compile() {
+
+ econf `use_enable doc gtk-doc` || die
+
+ make || die
+
+}
+
+src_install() {
+
+ einstall || die
+
+ rm -rf ${D}/usr/share/doc/libots
+
+ dodoc AUTHORS BUGS COPYING ChangeLog HACKING INSTALL NEWS README TODO
+
+ cd ${S}/doc/html
+ dohtml -r ./
+}