summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-09-17 17:15:50 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-09-17 17:15:50 +0000
commitb545affd6c5e3d8322c3eea850841a382cc7509a (patch)
treef6411c866cc568d5bf69bfd8891516111fa1742d /app-text/pandoc
parentdev-haskell/stringable: 0.1.2 (diff)
downloadgentoo-2-b545affd6c5e3d8322c3eea850841a382cc7509a.tar.gz
gentoo-2-b545affd6c5e3d8322c3eea850841a382cc7509a.tar.bz2
gentoo-2-b545affd6c5e3d8322c3eea850841a382cc7509a.zip
app-text/pandoc: 1.12
(Portage version: 2.2.4/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'app-text/pandoc')
-rw-r--r--app-text/pandoc/ChangeLog8
-rw-r--r--app-text/pandoc/metadata.xml1
-rw-r--r--app-text/pandoc/pandoc-1.12.ebuild76
3 files changed, 84 insertions, 1 deletions
diff --git a/app-text/pandoc/ChangeLog b/app-text/pandoc/ChangeLog
index 0ed2cca581da..299e0f3af3fc 100644
--- a/app-text/pandoc/ChangeLog
+++ b/app-text/pandoc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/pandoc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/ChangeLog,v 1.18 2013/09/14 01:12:04 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/ChangeLog,v 1.19 2013/09/17 17:15:50 qnikst Exp $
+
+*pandoc-1.12 (17 Sep 2013)
+
+ 17 Sep 2013; Alexander Vershilov <qnikst@gentoo.org> +pandoc-1.12.ebuild,
+ metadata.xml:
+ app-text/pandoc: 1.12
*pandoc-1.11.1-r1 (14 Sep 2013)
diff --git a/app-text/pandoc/metadata.xml b/app-text/pandoc/metadata.xml
index f4bb8363bde6..053d5691185c 100644
--- a/app-text/pandoc/metadata.xml
+++ b/app-text/pandoc/metadata.xml
@@ -17,5 +17,6 @@
</longdescription>
<use>
<flag name="embed_data_files">Embed data files in binary for relocatable executable.</flag>
+ <flag name="http-conduit">Enable downloading of resources over https.</flag>
</use>
</pkgmetadata>
diff --git a/app-text/pandoc/pandoc-1.12.ebuild b/app-text/pandoc/pandoc-1.12.ebuild
new file mode 100644
index 000000000000..f48debd8adff
--- /dev/null
+++ b/app-text/pandoc/pandoc-1.12.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/pandoc-1.12.ebuild,v 1.1 2013/09/17 17:15:50 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion between markup formats"
+HOMEPAGE="http://johnmacfarlane.net/pandoc"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="embed_data_files +http-conduit"
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?] <dev-haskell/aeson-0.7:=[profile?]
+ >=dev-haskell/attoparsec-0.10:=[profile?] <dev-haskell/attoparsec-0.11:=[profile?]
+ >=dev-haskell/base64-bytestring-0.1:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?] <dev-haskell/blaze-html-0.7:=[profile?]
+ >=dev-haskell/blaze-markup-0.5.1:=[profile?] <dev-haskell/blaze-markup-0.6:=[profile?]
+ >=dev-haskell/data-default-0.4:=[profile?] <dev-haskell/data-default-0.6:=[profile?]
+ >=dev-haskell/extensible-exceptions-0.1:=[profile?] <dev-haskell/extensible-exceptions-0.2:=[profile?]
+ >=dev-haskell/highlighting-kate-0.5.5:=[profile?] <dev-haskell/highlighting-kate-0.6:=[profile?]
+ >=dev-haskell/hslua-0.3:=[profile?] <dev-haskell/hslua-0.4:=[profile?]
+ >=dev-haskell/http-4000.0.5:=[profile?] <dev-haskell/http-4000.3:=[profile?]
+ >=dev-haskell/mtl-1.1:=[profile?] <dev-haskell/mtl-2.2:=[profile?]
+ >=dev-haskell/network-2:=[profile?] <dev-haskell/network-2.5:=[profile?]
+ >=dev-haskell/pandoc-types-1.12:=[profile?] <dev-haskell/pandoc-types-1.13:=[profile?]
+ >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/random-1:=[profile?] <dev-haskell/random-1.1:=[profile?]
+ >=dev-haskell/stringable-0.1:=[profile?] <dev-haskell/stringable-0.2:=[profile?]
+ >=dev-haskell/syb-0.1:=[profile?] <dev-haskell/syb-0.5:=[profile?]
+ >=dev-haskell/tagsoup-0.12.5:=[profile?] <dev-haskell/tagsoup-0.14:=[profile?]
+ >=dev-haskell/temporary-1.1:=[profile?] <dev-haskell/temporary-1.2:=[profile?]
+ >=dev-haskell/texmath-0.6.4:=[profile?] <dev-haskell/texmath-0.7:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-0.12:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.11:=[profile?]
+ >=dev-haskell/xml-1.3.12:=[profile?] <dev-haskell/xml-1.4:=[profile?]
+ >=dev-haskell/yaml-0.8.3:=[profile?] <dev-haskell/yaml-0.9:=[profile?]
+ >=dev-haskell/zip-archive-0.1.3.3:=[profile?] <dev-haskell/zip-archive-0.2:=[profile?]
+ >=dev-haskell/zlib-0.5:=[profile?] <dev-haskell/zlib-0.6:=[profile?]
+ >=dev-lang/ghc-7.0.1:=
+ http-conduit? ( >=dev-haskell/http-conduit-1.9:=[profile?] <dev-haskell/http-conduit-1.10:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?] <dev-haskell/http-types-0.9:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10.0.0
+ test? ( >=dev-haskell/ansi-terminal-0.5 <dev-haskell/ansi-terminal-0.7
+ >=dev-haskell/diff-0.2 <dev-haskell/diff-0.4
+ >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.3
+ >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-2.7
+ >=dev-haskell/test-framework-0.3 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2 <dev-haskell/test-framework-hunit-0.4
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 <dev-haskell/test-framework-quickcheck2-0.4 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag embed_data_files embed_data_files) \
+ $(cabal_flag http-conduit http-conduit)
+}
+
+src_install() {
+ cabal_src_install
+
+ doman "${S}/man/man1/${PN}.1"
+
+ # COPYING is installed by the Cabal eclass
+ dodoc README COPYRIGHT changelog
+}