summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-19 16:00:02 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-19 16:00:02 +0000
commit1a97843d5771b0872b73dec68b750815b9fec06e (patch)
tree28a7516b320b75e0dd4e46c4ba0ccdfec85f7fab /app-text/pdf2djvu
parentfix typo in ebuilds (diff)
downloadgentoo-2-1a97843d5771b0872b73dec68b750815b9fec06e.tar.gz
gentoo-2-1a97843d5771b0872b73dec68b750815b9fec06e.tar.bz2
gentoo-2-1a97843d5771b0872b73dec68b750815b9fec06e.zip
Version bump to fix building with poppler >= 0.18 wrt #384985 by Guillaume Horel
(Portage version: 2.2.0_alpha69/cvs/Linux x86_64)
Diffstat (limited to 'app-text/pdf2djvu')
-rw-r--r--app-text/pdf2djvu/ChangeLog8
-rw-r--r--app-text/pdf2djvu/pdf2djvu-0.7.11.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/app-text/pdf2djvu/ChangeLog b/app-text/pdf2djvu/ChangeLog
index 10b91853c1b1..ff27c5935316 100644
--- a/app-text/pdf2djvu/ChangeLog
+++ b/app-text/pdf2djvu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/pdf2djvu
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2djvu/ChangeLog,v 1.7 2011/08/31 04:21:08 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2djvu/ChangeLog,v 1.8 2011/10/19 16:00:02 ssuominen Exp $
+
+*pdf2djvu-0.7.11 (19 Oct 2011)
+
+ 19 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> +pdf2djvu-0.7.11.ebuild:
+ Version bump to fix building with poppler >= 0.18 wrt #384985 by Guillaume
+ Horel
31 Aug 2011; Tim Harder <radhermit@gentoo.org> -pdf2djvu-0.7.7.ebuild,
-pdf2djvu-0.7.8.ebuild:
diff --git a/app-text/pdf2djvu/pdf2djvu-0.7.11.ebuild b/app-text/pdf2djvu/pdf2djvu-0.7.11.ebuild
new file mode 100644
index 000000000000..a25e7d022fb9
--- /dev/null
+++ b/app-text/pdf2djvu/pdf2djvu-0.7.11.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2djvu/pdf2djvu-0.7.11.ebuild,v 1.1 2011/10/19 16:00:02 ssuominen Exp $
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="convert PDF files to DjVu ones"
+HOMEPAGE="http://code.google.com/p/pdf2djvu/"
+SRC_URI="http://pdf2djvu.googlecode.com/files/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="graphicsmagick nls openmp"
+
+RDEPEND=">=app-text/djvu-3.5.21
+ >=app-text/poppler-0.16.7[xpdf-headers]
+ dev-libs/libxml2
+ dev-libs/libxslt
+ graphicsmagick? ( media-gfx/graphicsmagick )"
+DEPEND="${RDEPEND}
+ dev-cpp/pstreams
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ local openmp=disable
+ use openmp && tc-has-openmp && openmp=enable
+
+ econf \
+ --${openmp}-openmp \
+ $(use_enable nls) \
+ $(use_with graphicsmagick)
+}
+
+src_test() {
+ use graphicsmagick && emake test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc doc/{changelog,*.txt}
+}