summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-01-20 04:11:29 +0000
committerMamoru Komachi <usata@gentoo.org>2005-01-20 04:11:29 +0000
commite531d4fa23c4bad4aca0f171d897abc10b5b48c4 (patch)
treefc9086b3248a9fbb91001aa273bdb3f50cff7f9c /app-text/pspresent/pspresent-1.2.ebuild
parentVersion bump. (diff)
downloadgentoo-2-e531d4fa23c4bad4aca0f171d897abc10b5b48c4.tar.gz
gentoo-2-e531d4fa23c4bad4aca0f171d897abc10b5b48c4.tar.bz2
gentoo-2-e531d4fa23c4bad4aca0f171d897abc10b5b48c4.zip
Version bumped. This closes bug #76751.
Diffstat (limited to 'app-text/pspresent/pspresent-1.2.ebuild')
-rw-r--r--app-text/pspresent/pspresent-1.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/pspresent/pspresent-1.2.ebuild b/app-text/pspresent/pspresent-1.2.ebuild
new file mode 100644
index 000000000000..612a8d8508c8
--- /dev/null
+++ b/app-text/pspresent/pspresent-1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pspresent/pspresent-1.2.ebuild,v 1.1 2005/01/20 04:11:27 usata Exp $
+
+IUSE="xinerama"
+
+DESCRIPTION="A tool to display full-screen PostScript presentations."
+SRC_URI="http://www.cse.unsw.edu.au/~matthewc/pspresent/${P}.tar.gz"
+HOMEPAGE="http://www.cse.unsw.edu.au/~matthewc/pspresent/"
+
+RDEPEND="virtual/libc
+ virtual/x11
+ virtual/ghostscript"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+PROVIDE="virtual/psviewer"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_compile()
+{
+ if ! use xinerama ; then
+ sed -i -e "/^XINERAMA/s/^/#/g" Makefile
+ fi
+ make pspresent || die "make failed"
+}
+
+src_install()
+{
+ dobin pspresent
+ doman pspresent.1
+ dodoc COPYING
+}