summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-03 14:15:17 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-03 14:15:17 +0000
commitf6687c4b11b11cc053d600cfeb87e3f9987013e9 (patch)
treee24771ad23d83b4470040f246a27da9c4a630379 /app-text/pstotext/files/1.9-flags.patch
parentadd ~arm, bug #336158 (diff)
downloadgentoo-2-f6687c4b11b11cc053d600cfeb87e3f9987013e9.tar.gz
gentoo-2-f6687c4b11b11cc053d600cfeb87e3f9987013e9.tar.bz2
gentoo-2-f6687c4b11b11cc053d600cfeb87e3f9987013e9.zip
QA, removed old, respecting LDFLAGS/CFLAGS/CC, 335595
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'app-text/pstotext/files/1.9-flags.patch')
-rw-r--r--app-text/pstotext/files/1.9-flags.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/pstotext/files/1.9-flags.patch b/app-text/pstotext/files/1.9-flags.patch
new file mode 100644
index 000000000000..6f3c9b68d82c
--- /dev/null
+++ b/app-text/pstotext/files/1.9-flags.patch
@@ -0,0 +1,36 @@
+diff --git a/Makefile b/Makefile
+index 551e3b8..1d55ebe 100644
+--- a/Makefile
++++ b/Makefile
+@@ -9,7 +9,7 @@
+ # commenting out the includes of ptotdll.h in ptotdll.c and main.c.
+ # PMcJ 6 Sep 96
+
+-CC=gcc
++CC ?= gcc
+ #CC=cc -std
+
+ BUNDLE = ocr.h rot270.h rot90.h
+@@ -17,18 +17,18 @@ BUNDLE = ocr.h rot270.h rot90.h
+ all: pstotext
+
+ main.o: main.c ptotdll.h bundle.h ocr.h rot270.h rot90.h
+- $(CC) -c $*.c
++ $(CC) $(CFLAGS) -c $*.c
+
+ ptotdll.o: ptotdll.c ptotdll.h
+- $(CC) -c $*.c
++ $(CC) $(CFLAGS) -c $*.c
+
+ pstotext: bundle.o main.o ptotdll.o
+- $(CC) -o pstotext main.o bundle.o ptotdll.o -lm
++ $(CC) $(CFLAGS) $(LDFLAGS) -o pstotext main.o bundle.o ptotdll.o -lm
+
+ .SUFFIXES: .ps
+
+ .c.o:
+- $(CC) -c $*.c
++ $(CC) $(CFLAGS) -c $*.c
+
+ # "Bundle" an Ascii file.
+ .ps.h: