summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-03-30 14:55:56 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-03-30 14:55:56 +0000
commit3014e46cec334eb67b166cea149404ff8f5b5b96 (patch)
tree67b5ac71825f1e7583f9c2cc948714da5f395bce /app-text/rcs/rcs-5.7-r2.ebuild
parentVersion bump for bug 87207. (diff)
downloadgentoo-2-3014e46cec334eb67b166cea149404ff8f5b5b96.tar.gz
gentoo-2-3014e46cec334eb67b166cea149404ff8f5b5b96.tar.bz2
gentoo-2-3014e46cec334eb67b166cea149404ff8f5b5b96.zip
first of all, the crappy conf.sh file in FILESDIR was really huge, and only slightly different from the conf.sh file in the sources. So, replaced that with a nice small patch, that will go away when -r2 becomes obsolete. Speaking of making it obsolete, -r3 is now here, with a brand spanking new patch from debian's unstable which fixes many things, including mktemp -> mkstemp, and bug #76550 by t0masek@galerka.com
(Portage version: 1.585-cvs)
Diffstat (limited to 'app-text/rcs/rcs-5.7-r2.ebuild')
-rw-r--r--app-text/rcs/rcs-5.7-r2.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-text/rcs/rcs-5.7-r2.ebuild b/app-text/rcs/rcs-5.7-r2.ebuild
index b9dcc75e63e1..8d295d83fd02 100644
--- a/app-text/rcs/rcs-5.7-r2.ebuild
+++ b/app-text/rcs/rcs-5.7-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rcs/rcs-5.7-r2.ebuild,v 1.19 2005/01/01 16:32:51 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rcs/rcs-5.7-r2.ebuild,v 1.20 2005/03/30 14:55:56 seemant Exp $
+
+inherit eutils
DESCRIPTION="Revision Control System"
HOMEPAGE="http://www.gnu.org/software/rcs/"
@@ -14,6 +16,11 @@ IUSE=""
DEPEND="virtual/libc"
RDEPEND="sys-apps/diffutils"
+src_unpack() {
+ unpack ${A}; cd ${S}
+ epatch ${FILESDIR}/conf.diff
+}
+
src_compile() {
# econf BREAKS this!
./configure \
@@ -21,7 +28,6 @@ src_compile() {
--host=${CHOST} \
--with-diffutils || die
- cp ${FILESDIR}/conf.sh src/conf.sh
emake || die
}