summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-27 12:39:41 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-27 12:39:41 +0000
commit2e52d5c70bcb07a32f81446aac69454d5abbfe03 (patch)
tree53afc2413d7fc49a1010cdddac12638a12f5dc8f /app-text/ronn
parentAdd ruby19. (diff)
downloadgentoo-2-2e52d5c70bcb07a32f81446aac69454d5abbfe03.tar.gz
gentoo-2-2e52d5c70bcb07a32f81446aac69454d5abbfe03.tar.bz2
gentoo-2-2e52d5c70bcb07a32f81446aac69454d5abbfe03.zip
Add ruby19. Fix test suite to always use the ruby interpreter tested.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'app-text/ronn')
-rw-r--r--app-text/ronn/ChangeLog5
-rw-r--r--app-text/ronn/ronn-0.7.3.ebuild9
2 files changed, 11 insertions, 3 deletions
diff --git a/app-text/ronn/ChangeLog b/app-text/ronn/ChangeLog
index 4308d491a00a..a370d94c7e54 100644
--- a/app-text/ronn/ChangeLog
+++ b/app-text/ronn/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/ronn
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ChangeLog,v 1.5 2011/08/07 19:00:11 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ChangeLog,v 1.6 2011/12/27 12:39:41 graaff Exp $
+
+ 27 Dec 2011; Hans de Graaff <graaff@gentoo.org> ronn-0.7.3.ebuild:
+ Add ruby19. Fix test suite to always use the ruby interpreter tested.
07 Aug 2011; Raúl Porcel <armin76@gentoo.org> ronn-0.7.3.ebuild:
Add ~ia64/~sparc
diff --git a/app-text/ronn/ronn-0.7.3.ebuild b/app-text/ronn/ronn-0.7.3.ebuild
index cb1a8f6dd970..c83408bd56b1 100644
--- a/app-text/ronn/ronn-0.7.3.ebuild
+++ b/app-text/ronn/ronn-0.7.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ronn-0.7.3.ebuild,v 1.5 2011/08/07 19:00:11 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ronn-0.7.3.ebuild,v 1.6 2011/12/27 12:39:41 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ree18"
+USE_RUBY="ruby18 ruby19 ree18"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGES README.md"
@@ -24,6 +24,11 @@ ruby_add_rdepend "
>=dev-ruby/mustache-0.7.0
>=dev-ruby/rdiscount-1.5.8"
+each_ruby_prepare() {
+ # Make sure that we always use the right interpreter during tests.
+ sed -i -e "/output/ s:ronn:${RUBY} bin/ronn:" test/test_ronn.rb
+}
+
all_ruby_compile() {
PATH="${S}/bin:${PATH}" rake man || die
}