summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-03-25 20:03:34 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-03-25 20:03:34 +0000
commit06a67edfb4668c2957e4202c351d526d58ad730c (patch)
tree24c7b8eb8e4e946d9df088de82703d0ecfde813d /app-text/scrollkeeper
parentadding scrollkeeper 0.3.4 (diff)
downloadgentoo-2-06a67edfb4668c2957e4202c351d526d58ad730c.tar.gz
gentoo-2-06a67edfb4668c2957e4202c351d526d58ad730c.tar.bz2
gentoo-2-06a67edfb4668c2957e4202c351d526d58ad730c.zip
adding devel scrollkeeper
Diffstat (limited to 'app-text/scrollkeeper')
-rw-r--r--app-text/scrollkeeper/files/digest-scrollkeeper-0.3.4-r41
-rw-r--r--app-text/scrollkeeper/scrollkeeper-0.3.4-r4.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-text/scrollkeeper/files/digest-scrollkeeper-0.3.4-r4 b/app-text/scrollkeeper/files/digest-scrollkeeper-0.3.4-r4
new file mode 100644
index 000000000000..6431b89c11cc
--- /dev/null
+++ b/app-text/scrollkeeper/files/digest-scrollkeeper-0.3.4-r4
@@ -0,0 +1 @@
+MD5 952f66d4b14477f0f4c44f203b0c43d1 scrollkeeper-0.3.4.tar.bz2 310698
diff --git a/app-text/scrollkeeper/scrollkeeper-0.3.4-r4.ebuild b/app-text/scrollkeeper/scrollkeeper-0.3.4-r4.ebuild
new file mode 100644
index 000000000000..ad9fc471c195
--- /dev/null
+++ b/app-text/scrollkeeper/scrollkeeper-0.3.4-r4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Spider <spider@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/app-text/scrollkeeper/scrollkeeper-0.2-r2.ebuild,v 1.1 2002/01/14 14:19:25 hallski Exp
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Scrollkeeper"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/releases/gnome-2.0-desktop-beta2/${P}.tar.bz2"
+HOMEPAGE="http://scrollkeeper.sourceforge.net"
+
+RDEPEND=">=dev-libs/libxml-1.8.11
+ >=sys-libs/zlib-1.1.3
+ >=app-text/docbook-xml-dtd-4.1.2-r2
+ >=app-text/docbook-sgml-utils-0.6.6
+ >=dev-util/intltool-0.17"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ] ; then
+ myconf ="--disable-nls"
+ fi
+ # hack around some to make sure we find the libxml2 includes. odd bug.
+ CFLAGS="${CFLAGS} -I/usr/include/libxml2/libxml"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ $myconf || die
+
+ emake || die
+}
+
+src_install() {
+ cd omf-install
+ cp Makefile Makefile.old
+ sed -e "s:scrollkeeper-update.*::g" Makefile.old > Makefile
+ rm Makefile.old
+ cd ${S}
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING* ChangeLog README NEWS
+}
+
+pkg_postinst() {
+ echo ">>> Rebuilding Scrollkeeper database..."
+ scrollkeeper-rebuilddb
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update -v
+}
+
+pkg_postrm() {
+ echo ">>> Scrollkeeper ${PV} unmerged, if you removed the package"
+ echo " you might want to clean up /var/lib/scrollkeeper."
+}