summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2013-01-24 20:56:27 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2013-01-24 20:56:27 +0000
commitb22f42854af9e1afbc6d1abf0cd4aa5655df049d (patch)
tree3ffe681f8d696273fdd8236761235ca4032c6d9d /app-text/sigil
parentDrop `die` as it does not make sense in many cases -- cross-compiling, deploy... (diff)
downloadgentoo-2-b22f42854af9e1afbc6d1abf0cd4aa5655df049d.tar.gz
gentoo-2-b22f42854af9e1afbc6d1abf0cd4aa5655df049d.tar.bz2
gentoo-2-b22f42854af9e1afbc6d1abf0cd4aa5655df049d.zip
version bump, solving bug #451568.
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, signed Manifest commit with key BB6C42C7)
Diffstat (limited to 'app-text/sigil')
-rw-r--r--app-text/sigil/ChangeLog9
-rw-r--r--app-text/sigil/sigil-0.6.2.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/app-text/sigil/ChangeLog b/app-text/sigil/ChangeLog
index d0dba0079214..ce286de01fd1 100644
--- a/app-text/sigil/ChangeLog
+++ b/app-text/sigil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/sigil
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sigil/ChangeLog,v 1.7 2012/10/31 20:42:20 flameeyes Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sigil/ChangeLog,v 1.8 2013/01/24 20:56:27 sbriesen Exp $
+
+*sigil-0.6.2 (24 Jan 2013)
+
+ 24 Jan 2013; Stefan Briesenick <sbriesen@gentoo.org> +sigil-0.6.2.ebuild:
+ version bump, solving bug #451568.
31 Oct 2012; Diego E. Pettenò <flameeyes@gentoo.org> sigil-0.6.0.ebuild:
QA: drop maximum boost version dep; if it fails to build, it has to be fixed.
diff --git a/app-text/sigil/sigil-0.6.2.ebuild b/app-text/sigil/sigil-0.6.2.ebuild
new file mode 100644
index 000000000000..c07774194b64
--- /dev/null
+++ b/app-text/sigil/sigil-0.6.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sigil/sigil-0.6.2.ebuild,v 1.1 2013/01/24 20:56:27 sbriesen Exp $
+
+EAPI=4
+CMAKE_BUILD_TYPE="Release"
+
+inherit eutils cmake-utils
+
+MY_P="Sigil-${PV}-Code"
+
+DESCRIPTION="Sigil is a multi-platform WYSIWYG ebook editor for ePub format."
+HOMEPAGE="http://code.google.com/p/sigil/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=sys-libs/zlib-1.2.7[minizip]
+ >=dev-libs/libpcre-8.31
+ >=dev-libs/boost-1.49
+ >=app-text/hunspell-1.3.2
+ >=dev-libs/xerces-c-3.1.1
+ >=x11-libs/qt-webkit-4.8:4
+ >=x11-libs/qt-svg-4.8:4
+ >=x11-libs/qt-gui-4.8:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+DOCS=( ChangeLog README )
+
+src_prepare() {
+ # use standard naming
+ mv -f README.txt README
+ mv -f ChangeLog.txt ChangeLog
+ edos2unix ChangeLog README
+}