summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-07-24 02:24:17 +0000
committerJeroen Roovers <jer@gentoo.org>2013-07-24 02:24:17 +0000
commit83e361f348db7cba7b519706cc9c6930f5232543 (patch)
treede0b961294c2264d7eb48e3985bed260b74dad26 /app-text/spellutils
parentQA: Removing stable keyword on arm as dev-python/lockfile doesn't have matchi... (diff)
downloadgentoo-2-83e361f348db7cba7b519706cc9c6930f5232543.tar.gz
gentoo-2-83e361f348db7cba7b519706cc9c6930f5232543.tar.bz2
gentoo-2-83e361f348db7cba7b519706cc9c6930f5232543.zip
Fix sandbox violation with LINGUAS=da (bug #465654).
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-text/spellutils')
-rw-r--r--app-text/spellutils/ChangeLog8
-rw-r--r--app-text/spellutils/files/spellutils-0.7-nls.patch13
-rw-r--r--app-text/spellutils/spellutils-0.7.ebuild26
3 files changed, 37 insertions, 10 deletions
diff --git a/app-text/spellutils/ChangeLog b/app-text/spellutils/ChangeLog
index 6900546e7237..093b70d6e390 100644
--- a/app-text/spellutils/ChangeLog
+++ b/app-text/spellutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/spellutils
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/spellutils/ChangeLog,v 1.13 2009/01/03 15:37:55 angelos Exp $
+# Copyright 2000-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/spellutils/ChangeLog,v 1.14 2013/07/24 02:24:17 jer Exp $
+
+ 24 Jul 2013; Jeroen Roovers <jer@gentoo.org> spellutils-0.7.ebuild,
+ +files/spellutils-0.7-nls.patch:
+ Fix sandbox violation with LINGUAS=da (bug #465654).
03 Jan 2009; Christoph Mende <angelos@gentoo.org> spellutils-0.7.ebuild:
QA: Respect CC (bug 243756)
diff --git a/app-text/spellutils/files/spellutils-0.7-nls.patch b/app-text/spellutils/files/spellutils-0.7-nls.patch
new file mode 100644
index 000000000000..ff36f67a9823
--- /dev/null
+++ b/app-text/spellutils/files/spellutils-0.7-nls.patch
@@ -0,0 +1,13 @@
+--- po/Makefile.in.in.orig 2000-04-16 12:04:50.000000000 +0200
++++ po/Makefile.in.in 2013-07-24 04:14:20.698869858 +0200
+@@ -119,8 +119,8 @@
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+ case "$$cat" in \
+- *.gmo) destdir=$(gnulocaledir);; \
+- *) destdir=$(localedir);; \
++ *.gmo) destdir=$(DESTDIR)/$(gnulocaledir);; \
++ *) destdir=$(DESTDIR)/$(localedir);; \
+ esac; \
+ lang=`echo $$cat | sed 's/\$(CATOBJEXT)$$//'`; \
+ dir=$$destdir/$$lang/LC_MESSAGES; \
diff --git a/app-text/spellutils/spellutils-0.7.ebuild b/app-text/spellutils/spellutils-0.7.ebuild
index 89d112ff3aaa..321d93a19f41 100644
--- a/app-text/spellutils/spellutils-0.7.ebuild
+++ b/app-text/spellutils/spellutils-0.7.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/spellutils/spellutils-0.7.ebuild,v 1.11 2009/01/03 15:37:55 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/spellutils/spellutils-0.7.ebuild,v 1.12 2013/07/24 02:24:17 jer Exp $
-inherit toolchain-funcs
+EAPI=5
+inherit eutils toolchain-funcs
DESCRIPTION="spellutils includes 'newsbody' (useful for spellchecking in mails, etc.)"
HOMEPAGE="http://home.worldonline.dk/byrial/spellutils/"
@@ -13,12 +14,21 @@ SLOT="0"
KEYWORDS="x86 ppc ~sparc alpha ~mips ~hppa amd64"
IUSE="nls"
-src_compile() {
+DEPEND="
+ nls? ( sys-devel/gettext)
+"
+DEPEND=""
+
+DOCS=( NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nls.patch
+}
+
+src_configure() {
econf $(use_enable nls)
- emake CC="$(tc-getCC)" || die "emake failed"
}
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc NEWS README
+src_compile() {
+ emake CC="$(tc-getCC)"
}