summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-10-21 17:09:55 +0000
committerJon Hood <squinky86@gentoo.org>2006-10-21 17:09:55 +0000
commit3a87c862333785d02e97b6f2597baa93e3d4f9d4 (patch)
tree3cd806103eb9cbb6ed7c84c61816d3713ee45beb /app-text/sword/sword-1.5.9.ebuild
parentFix sword dependency, remove old version. (diff)
downloadgentoo-2-3a87c862333785d02e97b6f2597baa93e3d4f9d4.tar.gz
gentoo-2-3a87c862333785d02e97b6f2597baa93e3d4f9d4.tar.bz2
gentoo-2-3a87c862333785d02e97b6f2597baa93e3d4f9d4.zip
Version bump to support bibletime-1.6.
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'app-text/sword/sword-1.5.9.ebuild')
-rw-r--r--app-text/sword/sword-1.5.9.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-text/sword/sword-1.5.9.ebuild b/app-text/sword/sword-1.5.9.ebuild
new file mode 100644
index 000000000000..62ececfce1ea
--- /dev/null
+++ b/app-text/sword/sword-1.5.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/sword-1.5.9.ebuild,v 1.1 2006/10/21 17:09:55 squinky86 Exp $
+
+DESCRIPTION="Library for Bible reading software."
+HOMEPAGE="http://www.crosswire.org/sword/"
+SRC_URI="http://www.crosswire.org/ftpmirror/pub/sword/source/v1.5/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="curl debug icu lucene"
+
+RDEPEND="sys-libs/zlib
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu )
+ lucene? ( dev-cpp/clucene )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ local myconf="--without-lucene --with-zlib --with-conf
+ $(use_enable debug) $(use_with curl)"
+
+ econf --with-zlib \
+ --with-conf \
+ $(use_enable curl) \
+ $(use_enable debug) \
+ $(use_with icu) \
+ $(use_enable lucene) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS CODINGSTYLE ChangeLog INSTALL README
+
+ cp -R samples examples ${D}/usr/share/doc/${PF}/
+}
+
+pkg_postinst() {
+ echo
+ einfo "Check out http://www.crosswire.org/sword/modules/"
+ einfo "to download modules that you would like to use with SWORD."
+ einfo "Follow module installation instructions found on"
+ einfo "the web or in /usr/share/doc/${PF}/INSTALL.gz."
+ echo
+}