summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-01-18 19:44:26 +0000
committerAron Griffis <agriffis@gentoo.org>2003-01-18 19:44:26 +0000
commit7b9aba9768709a2330a14cbd438451bb08629c8d (patch)
tree9bd2e0674dd16ea383c16df999b39f27f8e39bf8 /app-text/tetex
parentAdded ~mips to keywords (diff)
downloadgentoo-2-7b9aba9768709a2330a14cbd438451bb08629c8d.tar.gz
gentoo-2-7b9aba9768709a2330a14cbd438451bb08629c8d.tar.bz2
gentoo-2-7b9aba9768709a2330a14cbd438451bb08629c8d.zip
ooops, forgot to add these earlier
Diffstat (limited to 'app-text/tetex')
-rw-r--r--app-text/tetex/files/digest-tetex-1.0.7-r124
-rw-r--r--app-text/tetex/files/tetex-1.0.7-r12-gentoo.diff34
-rw-r--r--app-text/tetex/tetex-1.0.7-r12.ebuild183
3 files changed, 221 insertions, 0 deletions
diff --git a/app-text/tetex/files/digest-tetex-1.0.7-r12 b/app-text/tetex/files/digest-tetex-1.0.7-r12
new file mode 100644
index 000000000000..b0dad1273c70
--- /dev/null
+++ b/app-text/tetex/files/digest-tetex-1.0.7-r12
@@ -0,0 +1,4 @@
+MD5 2c6da2a45096c2fdc41b8de6a8af1a52 teTeX-src-1.0.7.tar.gz 8040192
+MD5 984530be5cc0dd73738de9d0067bc130 teTeX-texmf-gg-1.0.3.tar.bz2 35037546
+MD5 12925188fdadcd6a970c21bba3269fc2 ec-ready-mf-tfm.tar.gz 386630
+MD5 37393316b285926214c247acd55db743 teTeX-french.tar.gz 268161
diff --git a/app-text/tetex/files/tetex-1.0.7-r12-gentoo.diff b/app-text/tetex/files/tetex-1.0.7-r12-gentoo.diff
new file mode 100644
index 000000000000..b4ebc61103b8
--- /dev/null
+++ b/app-text/tetex/files/tetex-1.0.7-r12-gentoo.diff
@@ -0,0 +1,34 @@
+--- teTeX-1.0/texk/dvipsk/dvips.c.secure 2002-05-28 12:18:55.000000000 +0100
++++ teTeX-1.0/texk/dvipsk/dvips.c 2002-05-28 12:26:38.000000000 +0100
+@@ -64,7 +64,7 @@
+ Boolean cropmarks ; /* add cropmarks? */
+ Boolean abspage = 0 ; /* are page numbers absolute? */
+ Boolean tryepsf = 0 ; /* should we try to make it espf? */
+-Boolean secure = 0 ; /* make safe for suid */
++Boolean secure = 1 ; /* make safe for suid */
+ int collatedcopies = 1 ; /* how many collated copies? */
+ int sectioncopies = 1 ; /* how many times to repeat each section? */
+ integer pagecopies = 1 ; /* how many times to repeat each page? */
+@@ -280,7 +280,7 @@
+ "p # First page P s Load config.$s ",
+ #endif
+ "q* Run quietly ",
+-"r* Reverse order of pages R Run securely ",
++"r* Reverse order of pages R Run securely (default) ",
+ "s* Enclose output in save/restore S # Max section size in pages ",
+ "t s Paper format T c Specify desired page size ",
+ "u s PS mapfile U* Disable string param trick ",
+--- teTeX-1.0/texk/dvipsk/dvips.1.secure 2002-05-28 12:28:59.000000000 +0100
++++ teTeX-1.0/texk/dvipsk/dvips.1 2002-05-28 12:30:59.000000000 +0100
+@@ -328,7 +328,9 @@
+ .I \\\special{psfile="`zcat foo.ps.Z"}
+ or
+ .I \epsffile[72 72 540 720]{"`zcat screendump.ps.gz"}
+-are not executed.
++are not executed. This is the default; to run insecurely use the
++.B -R0
++option.
+ .TP
+ .B -s
+ Causes the entire global output to be enclosed in a save/restore pair.
+
diff --git a/app-text/tetex/tetex-1.0.7-r12.ebuild b/app-text/tetex/tetex-1.0.7-r12.ebuild
new file mode 100644
index 000000000000..b1743068a4e3
--- /dev/null
+++ b/app-text/tetex/tetex-1.0.7-r12.ebuild
@@ -0,0 +1,183 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/tetex/tetex-1.0.7-r12.ebuild,v 1.1 2003/01/18 19:44:26 agriffis Exp $
+
+inherit flag-o-matic
+
+IUSE="ncurses X libwww png zlib"
+
+TEXMFSRC="teTeX-texmf-gg-1.0.3.tar.bz2"
+
+S=${WORKDIR}/teTeX-1.0
+DESCRIPTION="teTeX is a complete TeX distribution"
+SRC_URI="ftp://sunsite.informatik.rwth-aachen.de/pub/comp/tex/teTeX/1.0/distrib/sources/teTeX-src-${PV}.tar.gz
+ ftp://ftp.dante.de/pub/tex/systems/unix/teTeX/1.0/contrib/ghibo/${TEXMFSRC}
+ http://www.ibiblio.org/gentoo/distfiles/ec-ready-mf-tfm.tar.gz
+ http://www.ibiblio.org/gentoo/distfiles/teTeX-french.tar.gz"
+HOMEPAGE="http://tug.cs.umb.edu/tetex/"
+
+KEYWORDS="x86 ppc sparc alpha"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="sys-apps/ed
+ X? ( virtual/x11 )
+ png? ( >=media-libs/libpng-1.2.1 )
+ ncurses? ( sys-libs/ncurses )
+ libwww? ( >=net-libs/libwww-5.3.2-r1 )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND=">=sys-devel/perl-5.2
+ dev-util/dialog"
+
+
+src_unpack() {
+ unpack teTeX-src-${PV}.tar.gz
+
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+
+ mkdir ${S}/texmf
+ cd ${S}/texmf
+ umask 022
+ echo ">>> Unpacking ${TEXMFSRC}"
+ tar --no-same-owner -xjf ${DISTDIR}/${TEXMFSRC} || die
+ echo ">>> Unpacking ec-ready-mf-tfm.tar.gz"
+ tar --no-same-owner -xzf ${DISTDIR}/ec-ready-mf-tfm.tar.gz -C .. || die
+ echo ">>> Unpacking teTeX-french.tar.gz"
+ tar --no-same-owner -xzf ${DISTDIR}/teTeX-french.tar.gz || die
+
+ # Fixes from way back ... not sure even Achim will
+ # still know why :/
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/teTeX-1.0-gentoo.diff || die
+ cd ${S}
+ patch -p0 < ${FILESDIR}/teTeX-1.0.dif || die
+
+ # Do not run config stuff
+ patch -p1 < ${FILESDIR}/${P}-dont-run-config.diff || die
+
+ # Fix for dvips to print directly.
+ patch -p1 < ${FILESDIR}/teTeX-1.0-dvips.diff || die
+
+ # Fix problem where the *.fmt files are not generated due to the LaTeX
+ # source being older than a year.
+ local x
+ for x in `find ${S}/texmf/ -type f -name '*.ini'`
+ do
+ cp ${x} ${x}.orig
+ sed -e '1i \\scrollmode' ${x}.orig > ${x}
+ rm -f ${x}.orig
+ done
+
+ # IMPORTANT! If you're having *.fmt problems, do this:
+ # fmtutil --all
+ # after the merge.
+
+}
+
+src_compile() {
+
+ local myconf=""
+ use X \
+ && myconf="--with-x" \
+ || myconf="--without-x"
+
+ use libwww \
+ && myconf="${myconf} --with-system-wwwlib
+ --with-libwww-include=/usr/include/w3c-libwww"
+
+ use png \
+ && myconf="${myconf} --with-system-pnglib"
+
+ use ncurses \
+ && myconf="${myconf} --with-system-ncurses"
+
+ use zlib \
+ && myconf="${myconf} --with-system-zlib"
+
+ econf \
+ --without-texinfo \
+ --without-dialog \
+ --disable-multiplatform \
+ --with-epsfwin \
+ --with-mftalkwin \
+ --with-regiswin \
+ --with-tektronixwin \
+ --with-unitermwin \
+ --with-ps=gs \
+ --enable-ipc \
+ --with-etex \
+ ${myconf} || die "econf failed"
+
+ emake
+}
+
+src_install() {
+
+ dodir /usr/share/
+ # Install texmf files
+ einfo "Installing texmf..."
+ cp -Rv texmf ${D}/usr/share || die "cp -Rv texmf failed"
+
+ einstall \
+ texmf=${D}/usr/share/texmf \
+ texmfmain=${D}/usr/share/texmf \
+ || die "einstall failed"
+
+ dodoc PROBLEMS README
+ docinto texk
+ dodoc texk/ChangeLog texk/README
+ docinto kpathesa
+ cd ${S}/texk/kpathsea
+ dodoc README* NEWS PROJECTS HIER
+ docinto dviljk
+ cd ${S}/texk/dviljk
+ dodoc AUTHORS README NEWS
+ docinto dvipsk
+ cd ${S}/texk/dvipsk
+ dodoc AUTHORS ChangeLog INSTALLATION README
+ docinto makeindexk
+ cd ${S}/texk/makeindexk
+ dodoc CONTRIB COPYING NEWS NOTES PORTING README
+ docinto ps2pkm
+ cd ${S}/texk/ps2pkm
+ dodoc ChangeLog CHANGES.type1 INSTALLATION README*
+ docinto web2c
+ cd ${S}/texk/web2c
+ dodoc AUTHORS ChangeLog NEWS PROJECTS README
+ docinto xdvik
+ cd ${S}/texk/xdvik
+ dodoc BUGS FAQ README*
+
+ #fix for conflicting readlink binary:
+ rm -f ${D}/bin/readlink
+ rm -f ${D}/usr/bin/readlink
+ #add /var/cache/fonts directory
+ dodir /var/cache/fonts
+
+ #fix for lousy upstream permisssions on /usr/share/texmf files
+ #NOTE: do not use fowners, as its not recursive ...
+ einfo "Fixing permissions..."
+ chown -R root.root ${D}/usr/share/texmf
+}
+
+pkg_postinst() {
+
+ if [ $ROOT = "/" ]
+ then
+ einfo "Configuring teTeX..."
+ mktexlsr &>/dev/null
+ texlinks &>/dev/null
+ texconfig init &>/dev/null
+ texconfig confall &>/dev/null
+ texconfig font vardir /var/cache/fonts &>/dev/null
+ einfo "Generating format files..."
+ fmtutil --missing &>/dev/null # This should generate all missing fmt files.
+
+ echo
+ einfo "Use 'texconfig font rw' to allow all users to generate fonts."
+ echo
+ fi
+}
+