summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-03-28 12:36:37 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-03-28 12:36:37 +0000
commit23b2a230cc58a014f3f98e5e8ef4f0f494373489 (patch)
tree0f288d36fa93189a68cedcc206a16b6b92f989ce /app-text/tokyodystopia/tokyodystopia-0.9.14.ebuild
parentApplied upstream patch to fix a crash on startup on the info applet caused by... (diff)
downloadgentoo-2-23b2a230cc58a014f3f98e5e8ef4f0f494373489.tar.gz
gentoo-2-23b2a230cc58a014f3f98e5e8ef4f0f494373489.tar.bz2
gentoo-2-23b2a230cc58a014f3f98e5e8ef4f0f494373489.zip
Bump, fixes #311407
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-text/tokyodystopia/tokyodystopia-0.9.14.ebuild')
-rw-r--r--app-text/tokyodystopia/tokyodystopia-0.9.14.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/tokyodystopia/tokyodystopia-0.9.14.ebuild b/app-text/tokyodystopia/tokyodystopia-0.9.14.ebuild
new file mode 100644
index 000000000000..6db868829a71
--- /dev/null
+++ b/app-text/tokyodystopia/tokyodystopia-0.9.14.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/tokyodystopia/tokyodystopia-0.9.14.ebuild,v 1.1 2010/03/28 12:36:37 patrick Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="A fulltext search engine for Tokyo Cabinet"
+HOMEPAGE="http://1978th.net/tokyodystopia/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+#dev-db/tokyocabinet for depend?
+DEPEND="dev-db/tokyocabinet"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup tyrant
+ enewuser tyrant -1 -1 /var/lib/${PN} tyrant
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_rpath.patch"
+ epatch "${FILESDIR}/fix_ldconfig.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ for x in /var/{lib,run,log}/${PN}; do
+ dodir "${x}" || die "Install failed"
+ fowners tyrant:tyrant "${x}"
+ done
+
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}