summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2014-01-06 02:01:51 +0000
committerChris Reffett <creffett@gentoo.org>2014-01-06 02:01:51 +0000
commita0b6d989f97ea490b817d25b966a3fff15eac6b6 (patch)
treec15a34b7f46c276afb175fd4a6e3a1fa6b5db0e9 /app-text/xiphos
parentfixed remote denial of ssh service (CVE-2013-6890, bug #495130), added purge ... (diff)
downloadgentoo-2-a0b6d989f97ea490b817d25b966a3fff15eac6b6.tar.gz
gentoo-2-a0b6d989f97ea490b817d25b966a3fff15eac6b6.tar.bz2
gentoo-2-a0b6d989f97ea490b817d25b966a3fff15eac6b6.zip
Bump to EAPI 5, change to python-single-r1
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'app-text/xiphos')
-rw-r--r--app-text/xiphos/ChangeLog8
-rw-r--r--app-text/xiphos/xiphos-3.1.5.ebuild24
2 files changed, 19 insertions, 13 deletions
diff --git a/app-text/xiphos/ChangeLog b/app-text/xiphos/ChangeLog
index 1d6a6d569f52..fd676d5934a0 100644
--- a/app-text/xiphos/ChangeLog
+++ b/app-text/xiphos/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/xiphos
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xiphos/ChangeLog,v 1.14 2012/05/04 03:33:12 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xiphos/ChangeLog,v 1.15 2014/01/06 02:01:51 creffett Exp $
+
+ 06 Jan 2014; Chris Reffett <creffett@gentoo.org> xiphos-3.1.5.ebuild:
+ Bump to EAPI 5, change to python-single-r1
04 May 2012; Jeff Horelick <jdhore@gentoo.org> xiphos-3.1.5.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -62,4 +65,3 @@
+metadata.xml:
Initial commit, bug 263309; Thanks to Greg <greg.hellings@gmail.com> for
original ebuild
-
diff --git a/app-text/xiphos/xiphos-3.1.5.ebuild b/app-text/xiphos/xiphos-3.1.5.ebuild
index c705913b2810..9f708773dc5e 100644
--- a/app-text/xiphos/xiphos-3.1.5.ebuild
+++ b/app-text/xiphos/xiphos-3.1.5.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xiphos/xiphos-3.1.5.ebuild,v 1.6 2012/05/04 03:33:12 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xiphos/xiphos-3.1.5.ebuild,v 1.7 2014/01/06 02:01:51 creffett Exp $
# TODO: waf-utils.eclass ?
-EAPI=4
-inherit flag-o-matic gnome2-utils python toolchain-funcs
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit flag-o-matic gnome2-utils python-single-r1 toolchain-funcs
DESCRIPTION="A bible study frontend for Sword (formerly known as GnomeSword)"
HOMEPAGE="http://xiphos.org/"
@@ -16,7 +17,10 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="dbus debug webkit"
-RDEPEND=">=app-text/sword-1.6.1
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-text/sword-1.6.1
>=dev-libs/glib-2
dev-libs/libxml2
gnome-base/gconf
@@ -24,7 +28,8 @@ RDEPEND=">=app-text/sword-1.6.1
>=gnome-extra/libgsf-1.14
x11-libs/gtk+:3
dbus? ( dev-libs/dbus-glib )
- webkit? ( net-libs/webkit-gtk:3 )"
+ webkit? ( net-libs/webkit-gtk:3 )
+"
DEPEND="${RDEPEND}
app-text/docbook2X
app-text/gnome-doc-utils
@@ -32,12 +37,11 @@ DEPEND="${RDEPEND}
dev-libs/libxslt
dev-util/intltool
virtual/pkgconfig
- || ( dev-lang/python:2.7 dev-lang/python:2.6 )
- sys-devel/gettext"
+ sys-devel/gettext
+"
pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
+ python-single-r1_pkg_setup
}
src_prepare() {