summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-21 04:19:15 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-21 04:19:15 +0000
commita6ffd95a4178c6c18b08858190341352d76303fd (patch)
tree4e06fa8aa4ce18584922e8908dcc7e1ca4238973 /app-text/xlsx2csv
parentAdd snapshot with support for newer versions of transmission. (diff)
downloadgentoo-2-a6ffd95a4178c6c18b08858190341352d76303fd.tar.gz
gentoo-2-a6ffd95a4178c6c18b08858190341352d76303fd.tar.bz2
gentoo-2-a6ffd95a4178c6c18b08858190341352d76303fd.zip
Version bump.
(Portage version: 2.2.0_alpha58/cvs/Linux x86_64)
Diffstat (limited to 'app-text/xlsx2csv')
-rw-r--r--app-text/xlsx2csv/ChangeLog7
-rw-r--r--app-text/xlsx2csv/xlsx2csv-0.15.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/app-text/xlsx2csv/ChangeLog b/app-text/xlsx2csv/ChangeLog
index cec8787e4ff2..ba6651afd24e 100644
--- a/app-text/xlsx2csv/ChangeLog
+++ b/app-text/xlsx2csv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/xlsx2csv
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xlsx2csv/ChangeLog,v 1.2 2011/07/19 19:12:20 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xlsx2csv/ChangeLog,v 1.3 2011/09/21 04:19:15 radhermit Exp $
+
+*xlsx2csv-0.15 (21 Sep 2011)
+
+ 21 Sep 2011; Tim Harder <radhermit@gentoo.org> +xlsx2csv-0.15.ebuild:
+ Version bump.
*xlsx2csv-0.14 (19 Jul 2011)
diff --git a/app-text/xlsx2csv/xlsx2csv-0.15.ebuild b/app-text/xlsx2csv/xlsx2csv-0.15.ebuild
new file mode 100644
index 000000000000..e8a4209994f8
--- /dev/null
+++ b/app-text/xlsx2csv/xlsx2csv-0.15.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xlsx2csv/xlsx2csv-0.15.ebuild,v 1.1 2011/09/21 04:19:15 radhermit Exp $
+
+EAPI=4
+
+DESCRIPTION="Convert MS Office xlsx files to CSV"
+HOMEPAGE="https://github.com/dilshod/xlsx2csv"
+SRC_URI="mirror://github/dilshod/${PN}/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="app-arch/unzip
+ test? ( dev-lang/python[xml] )"
+RDEPEND="dev-lang/python[xml]"
+
+S="${WORKDIR}/${PN}"
+
+src_test() {
+ local failure=0
+ for i in test/*.xlsx ; do
+ echo -n "test: $i "
+ if [[ $(basename $i) == "sheets.xlsx" ]] ; then
+ ./xlsx2csv.py -s 0 "$i" | diff -u "test/$(basename "$i" .xlsx).csv" - >/dev/null
+ else
+ ./xlsx2csv.py -i "$i" | diff -u "test/$(basename "$i" .xlsx).csv" - >/dev/null
+ fi
+ if [[ $? -ne 0 ]] ; then
+ echo "FAILED"
+ failure=1
+ else
+ echo "PASSED"
+ fi
+ done
+ [[ $failure -ne 0 ]] && die "tests failed"
+}
+
+src_install() {
+ newbin xlsx2csv.py xlsx2csv
+ dodoc CHANGELOG README
+}