summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-10-07 15:23:00 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-10-07 15:23:00 +0000
commit92825e576f0963ceaa8bebdb1ca60ec7ec6a32aa (patch)
treec7db1906c6fa5fc13c98dbda0a1b4c7abc3632cb /app-text/xpdf
parentadd patch to fix crash on accessing empty bookmarks, bug #51253 (Manifest rec... (diff)
downloadgentoo-2-92825e576f0963ceaa8bebdb1ca60ec7ec6a32aa.tar.gz
gentoo-2-92825e576f0963ceaa8bebdb1ca60ec7ec6a32aa.tar.bz2
gentoo-2-92825e576f0963ceaa8bebdb1ca60ec7ec6a32aa.zip
add patch to build with freetype-2.1.7, bug #65831
Diffstat (limited to 'app-text/xpdf')
-rw-r--r--app-text/xpdf/ChangeLog6
-rw-r--r--app-text/xpdf/files/xpdf-3.00-freetype-2.1.7.patch74
-rw-r--r--app-text/xpdf/xpdf-3.00-r2.ebuild3
3 files changed, 81 insertions, 2 deletions
diff --git a/app-text/xpdf/ChangeLog b/app-text/xpdf/ChangeLog
index 3eed477b2723..d5f862cf4dac 100644
--- a/app-text/xpdf/ChangeLog
+++ b/app-text/xpdf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/xpdf
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xpdf/ChangeLog,v 1.39 2004/10/07 15:19:44 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xpdf/ChangeLog,v 1.40 2004/10/07 15:23:00 lanius Exp $
+
+ 07 Oct 2004; Heinrich Wendel <lanius@gentoo.org>
+ +files/xpdf-3.00-freetype-2.1.7.patch, xpdf-3.00-r2.ebuild:
+ add patch to build with freetype-2.1.7, bug #65831
07 Oct 2004; Heinrich Wendel <lanius@gentoo.org>
+files/xpdf-3.00-empty-bookmark.patch, xpdf-3.00-r2.ebuild:
diff --git a/app-text/xpdf/files/xpdf-3.00-freetype-2.1.7.patch b/app-text/xpdf/files/xpdf-3.00-freetype-2.1.7.patch
new file mode 100644
index 000000000000..b6f789516ebc
--- /dev/null
+++ b/app-text/xpdf/files/xpdf-3.00-freetype-2.1.7.patch
@@ -0,0 +1,74 @@
+diff -Naur xpdf-3.00/configure.in xpdf-3.00.new/configure.in
+--- xpdf-3.00/configure.in 2004-01-22 02:26:44.000000000 +0100
++++ xpdf-3.00.new/configure.in 2004-09-29 19:27:16.089925504 +0200
+@@ -306,10 +306,13 @@
+ dnl ##### (Note: FT_Get_Name_Index was added in FT 2.0.5, and is
+ dnl ##### the reason that Xpdf requires 2.0.5+.)
+ smr_CHECK_LIB(freetype2, freetype, [FreeType2 font rasterizer - version 2.0.5+],
+- FT_Get_Name_Index, freetype/freetype.h, -lm)
++ FT_Get_Name_Index, freetype/ft2build.h, -lm)
+ if test x"$freetype2_LIBS" = x; then
+ smr_CHECK_LIB(freetype2, freetype, [FreeType2 font rasterizer - version 2.0.5+],
+- FT_Get_Name_Index, freetype.h, -lm)
++ FT_Get_Name_Index, ft2build.h, -lm)
++ if test "x$smr_have_freetype2_library" = xyes; then
++ AC_DEFINE(HAVE_FREETYPE_H)
++ fi
+ fi
+ AC_SUBST(freetype2_LIBS)
+ AC_SUBST(freetype2_CFLAGS)
+diff -Naur xpdf-3.00/splash/SplashFTFont.cc xpdf-3.00.new/splash/SplashFTFont.cc
+--- xpdf-3.00/splash/SplashFTFont.cc 2004-01-22 02:26:44.000000000 +0100
++++ xpdf-3.00.new/splash/SplashFTFont.cc 2004-09-29 19:27:46.527298320 +0200
+@@ -12,8 +12,10 @@
+ #pragma implementation
+ #endif
+
+-#include "freetype/ftoutln.h"
+-#include "freetype/internal/ftobjs.h" // needed for FT_New_Size decl
++#include <ft2build.h>
++#include FT_OUTLINE_H
++#include FT_GLYPH_H
++#include FT_SIZES_H // needed for FT_New_Size decl
+ #include "gmem.h"
+ #include "SplashMath.h"
+ #include "SplashGlyphBitmap.h"
+diff -Naur xpdf-3.00/splash/SplashFTFont.h xpdf-3.00.new/splash/SplashFTFont.h
+--- xpdf-3.00/splash/SplashFTFont.h 2004-01-22 02:26:44.000000000 +0100
++++ xpdf-3.00.new/splash/SplashFTFont.h 2004-09-29 19:27:16.091925200 +0200
+@@ -15,7 +15,8 @@
+ #pragma interface
+ #endif
+
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ #include "SplashFont.h"
+
+ class SplashFTFontFile;
+diff -Naur xpdf-3.00/splash/SplashFTFontEngine.h xpdf-3.00.new/splash/SplashFTFontEngine.h
+--- xpdf-3.00/splash/SplashFTFontEngine.h 2004-01-22 02:26:44.000000000 +0100
++++ xpdf-3.00.new/splash/SplashFTFontEngine.h 2004-09-29 19:27:16.091925200 +0200
+@@ -15,7 +15,8 @@
+ #pragma interface
+ #endif
+
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ #include "gtypes.h"
+
+ class SplashFontFile;
+diff -Naur xpdf-3.00/splash/SplashFTFontFile.h xpdf-3.00.new/splash/SplashFTFontFile.h
+--- xpdf-3.00/splash/SplashFTFontFile.h 2004-01-22 02:26:44.000000000 +0100
++++ xpdf-3.00.new/splash/SplashFTFontFile.h 2004-09-29 19:27:16.091925200 +0200
+@@ -15,7 +15,8 @@
+ #pragma interface
+ #endif
+
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ #include "SplashFontFile.h"
+
+ class SplashFontFileID;
diff --git a/app-text/xpdf/xpdf-3.00-r2.ebuild b/app-text/xpdf/xpdf-3.00-r2.ebuild
index 35b0bd63c5dd..30e6eba6827a 100644
--- a/app-text/xpdf/xpdf-3.00-r2.ebuild
+++ b/app-text/xpdf/xpdf-3.00-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xpdf/xpdf-3.00-r2.ebuild,v 1.4 2004/10/07 15:19:44 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xpdf/xpdf-3.00-r2.ebuild,v 1.5 2004/10/07 15:23:00 lanius Exp $
inherit eutils
@@ -50,6 +50,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/xpdf-3.00-truetype.diff.gz
+ epatch ${FILESDIR}/xpdf-3.00-freetype-2.1.7.patch
epatch ${FILESDIR}/xpdf-3.00-empty-bookmark.patch
use nodrm && epatch ${FILESDIR}/xpdf-3.00-nodrm.diff
}