summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-15 12:07:18 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-15 12:07:18 +0000
commit5d9c49424c930ad23602a44f0c022a5e75b1071f (patch)
treeb349c5ffb0c3441e5e2e9a1840a4666d1e4e6621 /app-text/zathura
parentsys-apps/x86info: Use linux-info.eclas instead of elog (diff)
downloadgentoo-2-5d9c49424c930ad23602a44f0c022a5e75b1071f.tar.gz
gentoo-2-5d9c49424c930ad23602a44f0c022a5e75b1071f.tar.bz2
gentoo-2-5d9c49424c930ad23602a44f0c022a5e75b1071f.zip
Version bump. Put rst2man.py (dev-python/docutils) behind USE="doc" because the tarball has prebuilt manpages wrt #420693 by "Cedric".
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'app-text/zathura')
-rw-r--r--app-text/zathura/ChangeLog8
-rw-r--r--app-text/zathura/zathura-0.2.0.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/app-text/zathura/ChangeLog b/app-text/zathura/ChangeLog
index 23ec15f920a9..6e9dd9b208e3 100644
--- a/app-text/zathura/ChangeLog
+++ b/app-text/zathura/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/zathura
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/zathura/ChangeLog,v 1.33 2012/06/15 11:38:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/zathura/ChangeLog,v 1.34 2012/06/15 12:07:18 ssuominen Exp $
+
+*zathura-0.2.0 (15 Jun 2012)
+
+ 15 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +zathura-0.2.0.ebuild:
+ Version bump. Put rst2man.py (dev-python/docutils) behind USE="doc" because
+ the tarball has prebuilt manpages wrt #420693 by "Cedric".
15 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -zathura-0.0.8.5.ebuild,
-zathura-0.1.1.ebuild:
diff --git a/app-text/zathura/zathura-0.2.0.ebuild b/app-text/zathura/zathura-0.2.0.ebuild
new file mode 100644
index 000000000000..7848575bec99
--- /dev/null
+++ b/app-text/zathura/zathura-0.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/zathura/zathura-0.2.0.ebuild,v 1.1 2012/06/15 12:07:18 ssuominen Exp $
+
+EAPI=4
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A highly customizable and functional document viewer"
+HOMEPAGE="http://pwmt.org/projects/zathura/"
+SRC_URI="http://pwmt.org/projects/${PN}/download/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc sqlite"
+
+RDEPEND=">=dev-libs/girara-0.1.3:2
+ >=dev-libs/glib-2
+ x11-libs/cairo
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( dev-python/docutils )"
+
+pkg_setup() {
+ myzathuraconf=(
+ ZATHURA_GTK_VERSION=2
+ WITH_SQLITE=$(usex sqlite 1 0)
+ LIBDIR='${PREFIX}'/$(get_libdir)
+ RSTTOMAN="$(type -P rst2man.py || echo true)"
+ CC="$(tc-getCC)"
+ SFLAGS=""
+ VERBOSE=1
+ DESTDIR="${D}"
+ )
+}
+
+src_compile() {
+ emake "${myzathuraconf[@]}"
+}
+
+src_install() {
+ emake "${myzathuraconf[@]}" install
+ dodoc AUTHORS
+}