summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-26 13:36:44 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-26 13:36:44 +0000
commit240a2930a43e6b0f96f71252d3b54eb94eeb99e8 (patch)
tree8e733e59f0e5e072965e510d3e1a50aed75bc9ed /app-text
parentUse tc-getCC from toolchain-funcs.eclass instead of \${CC}; fixes bug #68985 ... (diff)
downloadgentoo-2-240a2930a43e6b0f96f71252d3b54eb94eeb99e8.tar.gz
gentoo-2-240a2930a43e6b0f96f71252d3b54eb94eeb99e8.tar.bz2
gentoo-2-240a2930a43e6b0f96f71252d3b54eb94eeb99e8.zip
use $(tc-getCC)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/par/par-1.52.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/app-text/par/par-1.52.ebuild b/app-text/par/par-1.52.ebuild
index 31a55c8dd54b..b583771564d4 100644
--- a/app-text/par/par-1.52.ebuild
+++ b/app-text/par/par-1.52.ebuild
@@ -1,26 +1,29 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/par/par-1.52.ebuild,v 1.5 2004/09/11 15:20:19 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/par/par-1.52.ebuild,v 1.6 2004/10/26 13:35:11 vapier Exp $
-MY_P="Par${PV/./}"
+inherit toolchain-funcs
-DESCRIPTION="par is a paragraph reformatter, vaguely similar to fmt, but better"
+MY_P="Par${PV/./}"
+DESCRIPTION="a paragraph reformatter, vaguely similar to fmt, but better"
HOMEPAGE="http://www.nicemice.net/par/"
SRC_URI="http://www.nicemice.net/par/${MY_P/./}.tar.gz"
-LICENSE="freedist"
+LICENSE="freedist"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~mips ~amd64"
+KEYWORDS="~amd64 ~mips ~sparc ~x86"
IUSE=""
+
DEPEND="virtual/libc"
+
S=${WORKDIR}/${MY_P}
src_compile() {
- make -f protoMakefile CC="cc -c $CFLAGS"
+ make -f protoMakefile CC="$(tc-getCC) -c $CFLAGS"
}
src_install() {
- newbin par par-format
+ newbin par par-format || die
doman par.1
dodoc releasenotes par.doc
}