summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-07-05 11:40:06 +0000
committerSamuli Suominen <drac@gentoo.org>2007-07-05 11:40:06 +0000
commit30a6aee315f05db49600364ed2b30b4a955d2f36 (patch)
tree504037cce5397308567ce14d7da945205e8eb0fb /app-text
parentVersion bump (diff)
downloadgentoo-2-30a6aee315f05db49600364ed2b30b4a955d2f36.tar.gz
gentoo-2-30a6aee315f05db49600364ed2b30b4a955d2f36.tar.bz2
gentoo-2-30a6aee315f05db49600364ed2b30b4a955d2f36.zip
Patch for Python 2.5 compatibility and clean up.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/yodl/ChangeLog8
-rw-r--r--app-text/yodl/files/digest-yodl-1.31.18-r13
-rw-r--r--app-text/yodl/files/yodl-1.31.18-python-2.5.patch139
-rw-r--r--app-text/yodl/yodl-1.31.18-r1.ebuild63
4 files changed, 212 insertions, 1 deletions
diff --git a/app-text/yodl/ChangeLog b/app-text/yodl/ChangeLog
index 7a6249e02a16..443fb29682ef 100644
--- a/app-text/yodl/ChangeLog
+++ b/app-text/yodl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/yodl
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/yodl/ChangeLog,v 1.13 2007/03/13 00:54:45 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/yodl/ChangeLog,v 1.14 2007/07/05 11:40:06 drac Exp $
+
+*yodl-1.31.18-r1 (05 Jul 2007)
+
+ 05 Jul 2007; Samuli Suominen <drac@gentoo.org>
+ +files/yodl-1.31.18-python-2.5.patch, +yodl-1.31.18-r1.ebuild:
+ Patch for Python 2.5 compatibility and clean up.
13 Mar 2007; Leonardo Boshell <leonardop@gentoo.org> metadata.xml:
Replacing text-markup herd with the new sgml herd.
diff --git a/app-text/yodl/files/digest-yodl-1.31.18-r1 b/app-text/yodl/files/digest-yodl-1.31.18-r1
new file mode 100644
index 000000000000..471de0e6df24
--- /dev/null
+++ b/app-text/yodl/files/digest-yodl-1.31.18-r1
@@ -0,0 +1,3 @@
+MD5 247c5bf178baeb1f0b96511323f30a61 yodl-1.31.18.tar.gz 320053
+RMD160 71e42d72368a5850de89353880050feb026c58e0 yodl-1.31.18.tar.gz 320053
+SHA256 84bf33b538a791cd20e329fb2d49bc59d125922bf0b5ac6ecc42dacc05c5a967 yodl-1.31.18.tar.gz 320053
diff --git a/app-text/yodl/files/yodl-1.31.18-python-2.5.patch b/app-text/yodl/files/yodl-1.31.18-python-2.5.patch
new file mode 100644
index 000000000000..9d96bc3850f1
--- /dev/null
+++ b/app-text/yodl/files/yodl-1.31.18-python-2.5.patch
@@ -0,0 +1,139 @@
+--- yodl-1.31.18.orig/scripts/yodl2texinfo-post.py 1999-11-18 10:01:45.000000000 +0100
++++ yodl-1.31.18/scripts/yodl2texinfo-post.py 2007-04-04 20:01:50.000000000 +0200
+@@ -3,6 +3,7 @@
+ # yodl2texinfo-post.py
+ #
+ # (c) 1998,1999 Jan Nieuwenhuizen
++# 2007 convert regex/regsub to re Helmut Jarausch
+
+ program_name = 'yodl2texinfo-post'
+ version = '@TOPLEVEL_VERSION@'
+@@ -20,18 +21,19 @@
+ ## out/topinfo.texinfo:906: Node `@value{nodename}' previously defined at line 48.
+ ##
+ urg_value = 1
+-not_in_node_set = '[,:\.?!\\\'`{}]'
+-not_in_node = '.*[,:\.?!\\\'`{}].*'
++
+
+ import os
+ import sys
+
+ import getopt
+-from string import *
+-import regex
+-import regsub
++import re
+ import time
+
++not_in_node_set= re.compile(r'[,:.?!\'`{}]')
++not_in_node = re.compile(r'.*[,:.?!\'`{}].*')
++re_dnewl = re.compile('^\n\n')
++
+ def program_id ():
+ return program_name + ' version ' + version;
+
+@@ -98,6 +100,8 @@
+
+ TAB_POS = 34
+
++
++
+ class Pre_texinfo_file (Menu):
+ def __init__ (this, filename):
+ Menu.__init__ (this, 0, 'Top')
+@@ -141,16 +145,16 @@
+ return n
+
+ def eat_tag (this):
+- i = regex.search ('@TAGSTART@', this.s)
++ i = this.s.find('@TAGSTART@')
+ j = 0
+- if i < 0:
++ if i < 0 :
+ return 0
+- j = regex.search ('@TAGEND@', this.s[i:])
+- if j < 0:
++ j= this.s.find('@TAGEND@',i)
++ if j < 0 :
+ raise 'huh?'
+- j = i + j + len ('@TAGEND@')
++ j = j + len ('@TAGEND@')
+ tag = this.s[i + len ('@TAGSTART@'):j - len ('@TAGEND@')]
+- k = regex.search (' ', tag[1:]) + 1
++ k= tag.find(' ',1)
+ tag_name = tag[1:k]
+ tag_string = tag[k:len (tag) - 1]
+ while tag_string[:1] == ' ':
+@@ -161,13 +165,13 @@
+ # various other characters in node names too
+ #
+ if urg_value:
+- tag_string = regsub.gsub (not_in_node_set, '-', tag_string)
+- tag_string = regsub.gsub ('--', '-', tag_string)
++ tag_string = not_in_node_set.sub('-', tag_string)
++ tag_string = tag_string.replace('--','-')
+ # brr
+- tag_string = regsub.gsub ('--', '-', tag_string)
+- tag_string = regsub.gsub ('@code', '', tag_string)
+- tag_string = regsub.gsub ('@emph', '', tag_string)
+- tag_string = regsub.gsub ('@strong', '', tag_string)
++ tag_string = tag_string.replace('--','-')
++ tag_string = tag_string.replace('@code','')
++ tag_string = tag_string.replace('@emph','')
++ tag_string = tag_string.replace('@strong','')
+ if tag_name == 'menu':
+ this.default.top = 'Top'
+ n = this.new_node (i, tag_string)
+@@ -214,23 +218,23 @@
+ def create_node (this, n):
+ node = '@node '
+ set = ''
+- if not urg_value and regex.match (not_in_node, n.name) != -1:
++ if not urg_value and not_in_node.match(n.name) :
+ set = set + "@set nodename " + n.name + "\n"
+ node = node + "@value{nodename}"
+ else:
+ node = node + n.name
+ if not simple_nodes:
+- if not urg_value and regex.match (not_in_node, n.next) != -1:
++ if not urg_value and not_in_node.match(n.next) :
+ set = set + "@set nextname " + n.next + "\n"
+ node = node + ", @value{nextname}"
+ else:
+ node = node + ", " + n.next
+- if not urg_value and regex.match (not_in_node, n.prev) != -1:
++ if not urg_value and not_in_node.match(n.prev) :
+ set = set + "@set prevname " + n.prev + "\n"
+ node = node + ", @value{prevname}"
+ else:
+ node = node + ", " + n.prev
+- if not urg_value and regex.match (not_in_node, n.top) != -1:
++ if not urg_value and not_in_node.match(n.top) :
+ set = set + "@set topname " + n.top + "\n"
+ node = node + ", @value{topname}"
+ else:
+@@ -249,12 +253,12 @@
+ d = n.description
+ if not d:
+ d = n.name
+- if not urg_value and regex.match (not_in_node, n.name) != -1:
++ if not urg_value and not_in_node.match(n.name) :
+ menu = menu + "@set nodename " + n.name + "\n"
+ menu = menu + "* @value{nodename}::"
+ menu = menu + ' ' * (TAB_POS - len (n.name)) + d + "\n"
+ else:
+- menu = menu + ljust ('* ' + n.name + '::', TAB_POS) + d + "\n"
++ menu = menu + ('* ' + n.name + '::').ljust(TAB_POS) + d + "\n"
+ menu = menu + "@end menu\n"
+ this.s = this.s[:m.pos + this.offset] + menu + this.s[m.pos + this.offset:]
+ m.node_list[0].pos = m.node_list[0].pos - len (menu)
+@@ -309,7 +313,7 @@
+ this.parse ()
+ this.xrefs ()
+ this.nodes_and_menus ()
+- this.s = regsub.gsub ('^\n\n', '\n', this.s)
++ this.s = re_dnewl.sub ('\n', this.s)
+ this.s = '\n' + this.s
+ infotitle = ''
+ basename = os.path.basename (os.path.splitext (this.filename)[0])
diff --git a/app-text/yodl/yodl-1.31.18-r1.ebuild b/app-text/yodl/yodl-1.31.18-r1.ebuild
new file mode 100644
index 000000000000..85b3664f420a
--- /dev/null
+++ b/app-text/yodl/yodl-1.31.18-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/yodl/yodl-1.31.18-r1.ebuild,v 1.1 2007/07/05 11:40:06 drac Exp $
+
+inherit eutils
+
+HOMEPAGE="http://www.xs4all.nl/~jantien/yodl"
+SRC_URI="ftp://ftp.lilypond.org/pub/${PN}/development/${P}.tar.gz"
+DESCRIPTION="Yet oneOther Document Language"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~amd64"
+IUSE=""
+
+DEPEND="sys-devel/bison
+ sys-devel/flex
+ sys-apps/diffutils
+ sys-apps/groff
+ dev-lang/python
+ sys-apps/texinfo"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-python-2.5.patch
+ epatch "${FILESDIR}"/bison-configure.patch
+ epatch "${FILESDIR}"/${P}-debian.patch
+}
+
+src_compile() {
+ # Avoid a makefile bug if this var is already defined in the environment.
+ unset NAME
+
+ # The auto-dependencies break if ccache is used (for the first compile).
+ export CCACHE_DISABLE=yes
+ econf --datadir=/usr/share/${PN}
+ emake || die "emake failed."
+
+ cd Documentation
+ emake info || die "emake info failed."
+ ed out/yodl.info <<-EOM >/dev/null 2>&1
+ 3a
+ INFO-DIR-SECTION Miscellaneous
+ START-INFO-DIR-ENTRY
+ * yodl: (yodl). High level document preparation system.
+ END-INFO-DIR-ENTRY
+
+ .
+ wq
+ EOM
+}
+
+src_install() {
+ unset NAME
+
+ einstall datadir="${D}"/usr/share/${PN} || die "einstall failed."
+
+ doinfo Documentation/out/*.info*
+ dodoc ANNOUNCE-1.22 ChangeLog-1.22 CHANGES TODO VERSION \
+ {ANNOUNCE,AUTHORS,README,PATCHES}.txt
+}