summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2008-09-27 00:37:56 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2008-09-27 00:37:56 +0000
commit397f2e86fb43100a55212e626439bade5254790c (patch)
tree8d5b24b1fdd2742ee6b00847b2df0c2d9bec3ce4 /app-text
parentwhitespace (diff)
downloadgentoo-2-397f2e86fb43100a55212e626439bade5254790c.tar.gz
gentoo-2-397f2e86fb43100a55212e626439bade5254790c.tar.bz2
gentoo-2-397f2e86fb43100a55212e626439bade5254790c.zip
version bump for cairo 1.8
(Portage version: 2.2_rc9/cvs/Linux 2.6.27-rc3-git3 i686)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler-bindings/ChangeLog8
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.9.2.ebuild82
2 files changed, 89 insertions, 1 deletions
diff --git a/app-text/poppler-bindings/ChangeLog b/app-text/poppler-bindings/ChangeLog
index 0cc14ce4929d..cb889d1cd255 100644
--- a/app-text/poppler-bindings/ChangeLog
+++ b/app-text/poppler-bindings/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/poppler-bindings
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.99 2008/09/03 20:21:28 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.100 2008/09/27 00:37:56 compnerd Exp $
+
+*poppler-bindings-0.9.2 (27 Sep 2008)
+
+ 27 Sep 2008; Saleem Abdulrasool <compnerd@gentoo.org>
+ +poppler-bindings-0.9.2.ebuild:
+ version bump for cairo 1.8
*poppler-bindings-0.8.7 (03 Sep 2008)
diff --git a/app-text/poppler-bindings/poppler-bindings-0.9.2.ebuild b/app-text/poppler-bindings/poppler-bindings-0.9.2.ebuild
new file mode 100644
index 000000000000..05cc26420d4c
--- /dev/null
+++ b/app-text/poppler-bindings/poppler-bindings-0.9.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.9.2.ebuild,v 1.1 2008/09/27 00:37:56 compnerd Exp $
+
+EAPI="1"
+
+inherit autotools eutils multilib
+
+MY_P=${P/-bindings/}
+DESCRIPTION="rendering bindings for GUI toolkits for poppler"
+HOMEPAGE="http://poppler.freedesktop.org/"
+
+# Creating the testsuite tarball (must be done for every release)
+#
+# git://anongit.freedesktop.org/git/poppler/test
+# git archive --format=tar --prefix=test/ HEAD | bzip2 > ${PN}-test-${PV}.tar.bz2
+# upload to d.g.o/space/distfiles-local
+
+SRC_URI="http://poppler.freedesktop.org/${MY_P}.tar.gz
+ test? ( mirror://gentoo/poppler-test-0.9.2.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk qt3 cairo qt4 test"
+
+RDEPEND="~app-text/poppler-${PV}
+ cairo? ( >=x11-libs/cairo-1.4 )
+ gtk? (
+ >=x11-libs/gtk+-2.8
+ >=dev-libs/glib-2.8
+ )
+ qt3? ( =x11-libs/qt-3* )
+ qt4? ( || ( ( x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-test:4 )
+ =x11-libs/qt-4.3*:4 ) )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ test? ( gtk? ( >=gnome-base/libglade-2 ) )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack(){
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/poppler-0.6-bindings.patch
+
+ AT_M4DIR="m4" eautoreconf
+ cd poppler
+ ln -s /usr/lib/libpoppler.la
+}
+
+src_compile() {
+ # Configure needs help finding qt libs on multilib systems
+ export QTLIB="${QTDIR}/$(get_libdir)"
+ echo $QTLIB
+
+ econf $(use_enable cairo cairo-output) \
+ $(use_enable gtk poppler-glib) \
+ $(use_enable qt3 poppler-qt) \
+ $(use_enable qt4 poppler-qt4) \
+ || die "configuration failed"
+ cd poppler
+ if use cairo; then
+ emake libpoppler-cairo.la || die "cairo failed"
+ fi
+ if use qt4; then
+ emake libpoppler-arthur.la || die "arthur failed"
+ fi
+ cd ..
+ emake || die "compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ ewarn "You need to rebuild everything depending on poppler, use revdep-rebuild"
+}