summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-02-26 15:01:58 +0000
committerMichael Weber <xmw@gentoo.org>2015-02-26 15:01:58 +0000
commit3c649939fae2c34cdfa49f0984da69459e06083a (patch)
treefb08fa7ff4a49f1f1e5d3d69e1cdec17569a0a3d /app-text
parentVersion bump (bug 537404, thanks radhermit) (diff)
downloadgentoo-2-3c649939fae2c34cdfa49f0984da69459e06083a.tar.gz
gentoo-2-3c649939fae2c34cdfa49f0984da69459e06083a.tar.bz2
gentoo-2-3c649939fae2c34cdfa49f0984da69459e06083a.zip
Version bump (bug 532576, thanks Chris Torske). Add a patch for USE=-sqlite with installed sqlite:3.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zathura/ChangeLog11
-rw-r--r--app-text/zathura/files/zathura-0.3.2-no-sqlite.patch11
-rw-r--r--app-text/zathura/zathura-0.3.2.ebuild76
3 files changed, 96 insertions, 2 deletions
diff --git a/app-text/zathura/ChangeLog b/app-text/zathura/ChangeLog
index 9e98d38776f2..31297503f901 100644
--- a/app-text/zathura/ChangeLog
+++ b/app-text/zathura/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/zathura
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/zathura/ChangeLog,v 1.63 2014/10/24 17:58:58 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/zathura/ChangeLog,v 1.64 2015/02/26 15:01:58 xmw Exp $
+
+*zathura-0.3.2 (26 Feb 2015)
+
+ 26 Feb 2015; Michael Weber <xmw@gentoo.org>
+ +files/zathura-0.3.2-no-sqlite.patch, +zathura-0.3.2.ebuild:
+ Version bump (bug 532576, thanks Chris Torske). Add a patch for USE=-sqlite
+ with installed sqlite:3.
*zathura-0.3.1 (24 Oct 2014)
diff --git a/app-text/zathura/files/zathura-0.3.2-no-sqlite.patch b/app-text/zathura/files/zathura-0.3.2-no-sqlite.patch
new file mode 100644
index 000000000000..3a93db8d78fb
--- /dev/null
+++ b/app-text/zathura/files/zathura-0.3.2-no-sqlite.patch
@@ -0,0 +1,11 @@
+--- zathura-0.3.2/Makefile
++++ zathura-0.3.2/Makefile
+@@ -12,7 +12,7 @@
+ SOURCE = $(OSOURCE)
+ CPPFLAGS += -DWITH_SQLITE
+ else
+-SOURCE = $(filter-out database-sqlite.c,$(OSOURCE))
++SOURCE = $(filter-out ${PROJECT}/database-sqlite.c,$(OSOURCE))
+ endif
+
+ ifneq ($(WITH_MAGIC),0)
diff --git a/app-text/zathura/zathura-0.3.2.ebuild b/app-text/zathura/zathura-0.3.2.ebuild
new file mode 100644
index 000000000000..41e88394bc7b
--- /dev/null
+++ b/app-text/zathura/zathura-0.3.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/zathura/zathura-0.3.2.ebuild,v 1.1 2015/02/26 15:01:58 xmw Exp $
+
+EAPI=5
+
+inherit eutils fdo-mime multilib toolchain-funcs virtualx
+[[ ${PV} == 9999* ]] && inherit git-2
+
+DESCRIPTION="A highly customizable and functional document viewer"
+HOMEPAGE="http://pwmt.org/projects/zathura/"
+if ! [[ ${PV} == 9999* ]]; then
+SRC_URI="http://pwmt.org/projects/${PN}/download/${P}.tar.gz"
+fi
+EGIT_REPO_URI="git://git.pwmt.org/${PN}.git"
+EGIT_BRANCH="develop"
+
+LICENSE="ZLIB"
+SLOT="0"
+if ! [[ ${PV} == 9999* ]]; then
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+else
+KEYWORDS=""
+fi
+IUSE="+magic sqlite test"
+
+RDEPEND=">=dev-libs/girara-0.2.3:3=
+ >=dev-libs/glib-2.28:2=
+ x11-libs/cairo:=
+ >=x11-libs/gtk+-3.2:3
+ magic? ( sys-apps/file:= )
+ sqlite? ( dev-db/sqlite:3= )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( dev-libs/check )"
+
+pkg_setup() {
+ # TODO: Create ebuild for synctex and pass WITH_SYSTEM_SYNCTEX=1
+ myzathuraconf=(
+ WITH_SYSTEM_SYNCTEX=0
+ WITH_MAGIC=$(usex magic 1 0)
+ WITH_SQLITE=$(usex sqlite 1 0)
+ PREFIX="${EPREFIX}"/usr
+ LIBDIR='${PREFIX}'/$(get_libdir)
+ CC="$(tc-getCC)"
+ SFLAGS=''
+ VERBOSE=1
+ DESTDIR="${D}"
+ )
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-sqlite.patch
+}
+
+src_compile() {
+ emake "${myzathuraconf[@]}"
+}
+
+src_test() {
+ Xemake "${myzathuraconf[@]}" test
+}
+
+src_install() {
+ emake "${myzathuraconf[@]}" install
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}