summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-05-18 21:48:00 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-05-18 21:48:00 +0000
commit426419a0ed3e072abfa2a28bde119984a6f549db (patch)
tree06301ad624e25dc6135b31940350cf5b88d1797a /app-text
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-426419a0ed3e072abfa2a28bde119984a6f549db.tar.gz
gentoo-2-426419a0ed3e072abfa2a28bde119984a6f549db.tar.bz2
gentoo-2-426419a0ed3e072abfa2a28bde119984a6f549db.zip
Bump to 2.26.2. Bug fixes and translation updates.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/evince/ChangeLog8
-rw-r--r--app-text/evince/evince-2.24.2.ebuild6
-rw-r--r--app-text/evince/evince-2.26.2.ebuild71
3 files changed, 81 insertions, 4 deletions
diff --git a/app-text/evince/ChangeLog b/app-text/evince/ChangeLog
index 70434aa0fb52..5a856f0bbb91 100644
--- a/app-text/evince/ChangeLog
+++ b/app-text/evince/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/evince
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.171 2009/05/02 20:46:35 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.172 2009/05/18 21:48:00 eva Exp $
+
+*evince-2.26.2 (18 May 2009)
+
+ 18 May 2009; Gilles Dartiguelongue <eva@gentoo.org> evince-2.24.2.ebuild,
+ +evince-2.26.2.ebuild:
+ Bump to 2.26.2. Bug fixes and translation updates.
*evince-2.26.1 (02 May 2009)
diff --git a/app-text/evince/evince-2.24.2.ebuild b/app-text/evince/evince-2.24.2.ebuild
index 97d7138df7d2..b7b835f873d5 100644
--- a/app-text/evince/evince-2.24.2.ebuild
+++ b/app-text/evince/evince-2.24.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-2.24.2.ebuild,v 1.11 2009/04/27 13:13:34 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-2.24.2.ebuild,v 1.12 2009/05/18 21:48:00 eva Exp $
EAPI="2"
inherit eutils gnome2
@@ -58,8 +58,8 @@ pkg_setup() {
$(use_enable nautilus)"
}
-src_unpack() {
- gnome2_src_unpack
+src_prepare() {
+ gnome2_src_prepare
# Fix .desktop file so menu item shows up
epatch "${FILESDIR}"/${PN}-0.7.1-display-menu.patch
diff --git a/app-text/evince/evince-2.26.2.ebuild b/app-text/evince/evince-2.26.2.ebuild
new file mode 100644
index 000000000000..b8653ba69cb1
--- /dev/null
+++ b/app-text/evince/evince-2.26.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-2.26.2.ebuild,v 1.1 2009/05/18 21:48:00 eva Exp $
+
+EAPI="2"
+
+inherit eutils gnome2
+
+DESCRIPTION="Simple document viewer for GNOME"
+HOMEPAGE="http://www.gnome.org/projects/evince/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dbus debug djvu doc dvi gnome-keyring nautilus t1lib tiff"
+
+# FIXME: enable gobject-introspection when we have an ebuild for it.
+# Since 2.26.2, can handle poppler without cairo support. Make it optional ?
+RDEPEND="
+ >=app-text/libspectre-0.2.0
+ >=dev-libs/glib-2.18.0
+ >=dev-libs/libxml2-2.5
+ >=gnome-base/gconf-2
+ >=x11-libs/gtk+-2.12
+ >=x11-libs/libSM-1
+ >=x11-themes/gnome-icon-theme-2.17.1
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.22.0 )
+ nautilus? ( >=gnome-base/nautilus-2.10 )
+ >=virtual/poppler-glib-0.8[cairo]
+ dvi? (
+ virtual/tex-base
+ t1lib? ( >=media-libs/t1lib-5.0.0 ) )
+ tiff? ( >=media-libs/tiff-3.6 )
+ djvu? ( >=app-text/djvu-3.5.17 )"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.3.2
+ ~app-text/docbook-xml-dtd-4.1.2
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ doc? ( dev-util/gtk-doc )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+ELTCONF="--portage"
+RESTRICT="test"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --disable-introspection
+ --enable-pdf
+ --enable-comics
+ --enable-impress
+ --enable-thumbnailer
+ --with-gconf
+ $(use_enable dbus)
+ $(use_enable djvu)
+ $(use_enable dvi)
+ $(use_with gnome-keyring keyring)
+ $(use_enable t1lib)
+ $(use_enable tiff)
+ $(use_enable nautilus)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix .desktop file so menu item shows up
+ epatch "${FILESDIR}"/${PN}-0.7.1-display-menu.patch
+}