summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-29 23:24:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-29 23:24:21 +0000
commit503a2db8eb642d5c2fc018bce2b7ac15664b256d (patch)
treee9d7ff359f6ab17d1a46cd517915a200351acd8a /app-text
parentRestrict from stripping, as this is a binary-only package already stripped up... (diff)
downloadgentoo-2-503a2db8eb642d5c2fc018bce2b7ac15664b256d.tar.gz
gentoo-2-503a2db8eb642d5c2fc018bce2b7ac15664b256d.tar.bz2
gentoo-2-503a2db8eb642d5c2fc018bce2b7ac15664b256d.zip
Add patch to respect LDFLAGS and override CC and CFLAGS to use the correct ones.
(Portage version: 2.1_pre7-r2)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/rman/ChangeLog7
-rw-r--r--app-text/rman/files/rman-3.2-ldflags.patch13
-rw-r--r--app-text/rman/rman-3.2.ebuild9
3 files changed, 26 insertions, 3 deletions
diff --git a/app-text/rman/ChangeLog b/app-text/rman/ChangeLog
index 6a8322801981..add8a5e34619 100644
--- a/app-text/rman/ChangeLog
+++ b/app-text/rman/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/rman
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rman/ChangeLog,v 1.22 2006/03/09 22:15:39 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rman/ChangeLog,v 1.23 2006/03/29 23:24:21 flameeyes Exp $
+
+ 29 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/rman-3.2-ldflags.patch, rman-3.2.ebuild:
+ Add patch to respect LDFLAGS and override CC and CFLAGS to use the correct
+ ones.
09 Mar 2006; Aron Griffis <agriffis@gentoo.org> rman-3.2.ebuild:
Mark 3.2 stable on ia64
diff --git a/app-text/rman/files/rman-3.2-ldflags.patch b/app-text/rman/files/rman-3.2-ldflags.patch
new file mode 100644
index 000000000000..4a6f5f5d9eab
--- /dev/null
+++ b/app-text/rman/files/rman-3.2-ldflags.patch
@@ -0,0 +1,13 @@
+Index: rman-3.2/Makefile
+===================================================================
+--- rman-3.2.orig/Makefile
++++ rman-3.2/Makefile
+@@ -102,7 +102,7 @@ all: rman
+
+ # everyone but me zaps assertions with the -DNDEBUG flag
+ rman: rman.c Makefile
+- $(CC) -DNDEBUG $(defs) -DPOLYGLOTMANVERSION=\"$(version)\" $(CFLAGS) -o rman rman.c
++ $(CC) $(LDFLAGS) -DNDEBUG $(defs) -DPOLYGLOTMANVERSION=\"$(version)\" $(CFLAGS) -o rman rman.c
+
+
+ debug:
diff --git a/app-text/rman/rman-3.2.ebuild b/app-text/rman/rman-3.2.ebuild
index 6e3193663b70..0ffc13943de0 100644
--- a/app-text/rman/rman-3.2.ebuild
+++ b/app-text/rman/rman-3.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rman/rman-3.2.ebuild,v 1.9 2006/03/09 22:15:39 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rman/rman-3.2.ebuild,v 1.10 2006/03/29 23:24:21 flameeyes Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="PolyGlotMan man page translator AKA RosettaMan"
HOMEPAGE="http://polyglotman.sourceforge.net/"
@@ -19,6 +19,11 @@ DEPEND=""
src_unpack() {
unpack ${A}
epatch "${FILESDIR}"/${PF}-gentoo.diff || die "patch failed"
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {