summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-04-09 18:30:54 +0000
committerJon Hood <squinky86@gentoo.org>2004-04-09 18:30:54 +0000
commit50fb1c7e1feac80a9728d30d86e136c48362152a (patch)
tree2e49a09195ebac9a01b62e094f69bb828f75de28 /app-text
parentversion bump, thanks to me (Manifest recommit) (diff)
downloadgentoo-2-50fb1c7e1feac80a9728d30d86e136c48362152a.tar.gz
gentoo-2-50fb1c7e1feac80a9728d30d86e136c48362152a.tar.bz2
gentoo-2-50fb1c7e1feac80a9728d30d86e136c48362152a.zip
added warnings for curl support (bug #47318)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/bibletime/ChangeLog5
-rw-r--r--app-text/bibletime/bibletime-1.4.1.ebuild38
2 files changed, 40 insertions, 3 deletions
diff --git a/app-text/bibletime/ChangeLog b/app-text/bibletime/ChangeLog
index 6dc5d0879d5b..f198f9d9af01 100644
--- a/app-text/bibletime/ChangeLog
+++ b/app-text/bibletime/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for app-text/bibletime
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/ChangeLog,v 1.8 2004/04/08 22:23:45 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/ChangeLog,v 1.9 2004/04/09 18:30:54 squinky86 Exp $
*bibletime-1.4.1 (04 Apr 2004)
+ 09 Apr 2004; Jon Hood <squinky86@gentoo.org>:
+ added pre and post install information for curl support. (bug #47318)
+
04 Apr 2004; Jon Hood <squinky86@gentoo.org> bibletime-1.4.1.ebuild:
version bump, thanks to Timothy Stotts for the ebuild, bug #39300
diff --git a/app-text/bibletime/bibletime-1.4.1.ebuild b/app-text/bibletime/bibletime-1.4.1.ebuild
index 7cd8eb5b3ca0..151d6826e640 100644
--- a/app-text/bibletime/bibletime-1.4.1.ebuild
+++ b/app-text/bibletime/bibletime-1.4.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/bibletime-1.4.1.ebuild,v 1.1 2004/04/08 22:20:25 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/bibletime-1.4.1.ebuild,v 1.2 2004/04/09 18:30:54 squinky86 Exp $
inherit kde
need-kde 3
-IUSE=""
+IUSE="curl"
DESCRIPTION="BibleTime KDE Bible study application using the SWORD library."
HOMEPAGE="http://bibletime.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
@@ -14,3 +14,37 @@ SLOT="0"
KEYWORDS="~x86 ~ppc"
newdepend ">=app-text/sword-1.5.7
>=net-misc/curl-7.10"
+
+pkg_preinst() {
+ if [ ! "`use curl`" ] ; then
+ ewarn
+ ewarn "You do not have \"curl\" support enabled in your USE variable."
+ ewarn "This means SWORD may not have been compiled with curl support."
+ ewarn "If you wish to use BibleTime's ability to download modules"
+ ewarn "straight from the SWORD website, please add \"curl\" to your"
+ ewarn "USE variable in /etc/make.conf or make sure app-text/sword was"
+ ewarn "compiled with support for curl:"
+ ewarn " USE=\"curl\" emerge sword"
+ ewarn "Press ctrl+c to abort the merge of BibleTime if you want to"
+ ewarn "recompile SWORD with curl support."
+ ewarn
+ for TICKER in 1 2 3 4 5; do
+ echo -ne "\a" ; sleep 0.1 &>/dev/null ; sleep 0,1 &>/dev/null
+ echo -ne "\a" ; sleep 1
+ done
+ sleep 8
+ fi
+}
+
+pkg_postinst() {
+ if [ `use curl` ] ; then
+ einfo
+ einfo "To use BibleTime's ability to install modules from"
+ einfo "The SWORD Project's website, make sure that SWORD"
+ einfo "was compiled with curl support, either by making"
+ einfo "sure the \"curl\" USE flag is set in /etc/make.conf"
+ einfo "or by installing SWORD with:"
+ einfo " USE=\"curl\" emerge sword"
+ einfo
+ fi
+}