summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-08-04 20:26:17 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-08-04 20:26:17 +0000
commit6214c99aee245573e96b48ac3cebed057529e063 (patch)
tree64e4cced0251c1bf255d542b3f708f46d1301803 /app-text
parentAdd missing dev-haskell/old-time depend (diff)
downloadgentoo-2-6214c99aee245573e96b48ac3cebed057529e063.tar.gz
gentoo-2-6214c99aee245573e96b48ac3cebed057529e063.tar.bz2
gentoo-2-6214c99aee245573e96b48ac3cebed057529e063.zip
Add live ebuild
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libmwaw/ChangeLog7
-rw-r--r--app-text/libmwaw/libmwaw-9999.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/app-text/libmwaw/ChangeLog b/app-text/libmwaw/ChangeLog
index 0fce7e514152..ecbfd3b8803c 100644
--- a/app-text/libmwaw/ChangeLog
+++ b/app-text/libmwaw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/libmwaw
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libmwaw/ChangeLog,v 1.21 2015/07/22 19:33:29 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libmwaw/ChangeLog,v 1.22 2015/08/04 20:26:17 dilfridge Exp $
+
+*libmwaw-9999 (04 Aug 2015)
+
+ 04 Aug 2015; Andreas K. Huettel <dilfridge@gentoo.org> +libmwaw-9999.ebuild:
+ Add live ebuild
22 Jul 2015; Agostino Sarubbo <ago@gentoo.org> libmwaw-0.3.5.ebuild:
Stable for x86, wrt bug #555584
diff --git a/app-text/libmwaw/libmwaw-9999.ebuild b/app-text/libmwaw/libmwaw-9999.ebuild
new file mode 100644
index 000000000000..88c9849f4554
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libmwaw/libmwaw-9999.ebuild,v 1.1 2015/08/04 20:26:17 dilfridge Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://git.code.sf.net/p/libmwaw/libmwaw"
+inherit eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="http://sourceforge.net/p/libmwaw/wiki/Home/"
+[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46:=
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --with-sharedptr=boost \
+ --enable-zip \
+ --disable-werror \
+ $(use_enable static-libs static) \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}