summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-01-23 00:50:46 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-01-23 00:50:46 +0000
commit64100de669a5d764d67253c5990333ea838cea3b (patch)
treecf3f4e2cf256ea79762c4809690421609bf7974b /app-text
parentInitial import, thanks to all contributors on bug 151846. (diff)
downloadgentoo-2-64100de669a5d764d67253c5990333ea838cea3b.tar.gz
gentoo-2-64100de669a5d764d67253c5990333ea838cea3b.tar.bz2
gentoo-2-64100de669a5d764d67253c5990333ea838cea3b.zip
disable werror (fix build with ocaml-4), bug #442828
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/htmlc/ChangeLog8
-rw-r--r--app-text/htmlc/files/htmlc-2.21.0-werror.patch15
-rw-r--r--app-text/htmlc/htmlc-2.21.0.ebuild5
3 files changed, 24 insertions, 4 deletions
diff --git a/app-text/htmlc/ChangeLog b/app-text/htmlc/ChangeLog
index f90996653339..6e3fb60417ca 100644
--- a/app-text/htmlc/ChangeLog
+++ b/app-text/htmlc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/htmlc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmlc/ChangeLog,v 1.4 2012/07/24 10:51:37 johu Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmlc/ChangeLog,v 1.5 2013/01/23 00:50:46 aballier Exp $
+
+ 23 Jan 2013; Alexis Ballier <aballier@gentoo.org> htmlc-2.21.0.ebuild,
+ +files/htmlc-2.21.0-werror.patch:
+ disable werror (fix build with ocaml-4), bug #442828
24 Jul 2012; Johannes Huber <johu@gentoo.org> htmlc-2.21.0.ebuild:
Stable for x86, wrt bug #416525
diff --git a/app-text/htmlc/files/htmlc-2.21.0-werror.patch b/app-text/htmlc/files/htmlc-2.21.0-werror.patch
new file mode 100644
index 000000000000..feb35f54b8df
--- /dev/null
+++ b/app-text/htmlc/files/htmlc-2.21.0-werror.patch
@@ -0,0 +1,15 @@
+Index: htmlc-2.21.0/config/Makefile.in
+===================================================================
+--- htmlc-2.21.0.orig/config/Makefile.in
++++ htmlc-2.21.0/config/Makefile.in
+@@ -35,8 +35,8 @@ MANDIR = \$(PREFIXINSTALLDIR)/man/man\$(
+
+ # The Caml compilers (those defaults should be OK)
+ CAMLDEP = ocamldep
+-CAMLBYT = ocamlc -w A -warn-error A -g
+-CAMLBIN = ocamlopt -w A -warn-error A -inline 10000
++CAMLBYT = ocamlc -w A -g
++CAMLBIN = ocamlopt -w A -inline 10000
+ CAMLYAC = ocamlyacc -v
+ CAMLLEX = ocamllex
+
diff --git a/app-text/htmlc/htmlc-2.21.0.ebuild b/app-text/htmlc/htmlc-2.21.0.ebuild
index 508c4f11d65b..5e58b1ff251a 100644
--- a/app-text/htmlc/htmlc-2.21.0.ebuild
+++ b/app-text/htmlc/htmlc-2.21.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmlc/htmlc-2.21.0.ebuild,v 1.4 2012/07/24 10:51:37 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmlc/htmlc-2.21.0.ebuild,v 1.5 2013/01/23 00:50:46 aballier Exp $
EAPI=3
@@ -22,6 +22,7 @@ RDEPEND="${DEPEND}"
src_prepare() {
has_version '>=dev-lang/ocaml-3.12' && epatch "${FILESDIR}/${P}-ocaml312.patch"
+ epatch "${FILESDIR}/${P}-werror.patch"
}
src_configure() {