summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-10-10 16:27:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-10-10 16:27:23 +0000
commit6f5a13b59018c0139c85ef9cd55924e8a98f91a0 (patch)
treed02ba866479cf84ea3c985779f5016afeb69b357 /app-text
parentversion bump (diff)
downloadgentoo-2-6f5a13b59018c0139c85ef9cd55924e8a98f91a0.tar.gz
gentoo-2-6f5a13b59018c0139c85ef9cd55924e8a98f91a0.tar.bz2
gentoo-2-6f5a13b59018c0139c85ef9cd55924e8a98f91a0.zip
Use the kpathsea/version.h header when available. Fixes a build failure with TeX Live 2010.
(Portage version: 2.2_rc91/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xdvik/ChangeLog7
-rw-r--r--app-text/xdvik/files/xdvik-22.84.16-kpathsea_version.patch18
-rw-r--r--app-text/xdvik/xdvik-22.84.16.ebuild3
3 files changed, 26 insertions, 2 deletions
diff --git a/app-text/xdvik/ChangeLog b/app-text/xdvik/ChangeLog
index 5eb5095a3b3d..b9ad6ced1fbf 100644
--- a/app-text/xdvik/ChangeLog
+++ b/app-text/xdvik/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/xdvik
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xdvik/ChangeLog,v 1.73 2010/10/02 13:13:03 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xdvik/ChangeLog,v 1.74 2010/10/10 16:27:23 aballier Exp $
+
+ 10 Oct 2010; Alexis Ballier <aballier@gentoo.org> xdvik-22.84.16.ebuild,
+ +files/xdvik-22.84.16-kpathsea_version.patch:
+ Use the kpathsea/version.h header when available. Fixes a build failure
+ with TeX Live 2010.
02 Oct 2010; Fabian Groffen <grobian@gentoo.org> xdvik-22.84.16.ebuild:
Marked ~x64-macos, bug #333981
diff --git a/app-text/xdvik/files/xdvik-22.84.16-kpathsea_version.patch b/app-text/xdvik/files/xdvik-22.84.16-kpathsea_version.patch
new file mode 100644
index 000000000000..fb69d3d1294e
--- /dev/null
+++ b/app-text/xdvik/files/xdvik-22.84.16-kpathsea_version.patch
@@ -0,0 +1,18 @@
+kpathsea from TeX Live 2009 and later provides a version.h header with this
+definition. Use it because it causes definition conflicts with kpathsea from TeX
+Live 2010.
+
+Index: xdvik-22.84.16/texk/xdvik/xdvi.h
+===================================================================
+--- xdvik-22.84.16.orig/texk/xdvik/xdvi.h
++++ xdvik-22.84.16/texk/xdvik/xdvi.h
+@@ -242,8 +242,7 @@ typedef unsigned long xuint32;
+ #define LENGTH_OF_ULONG ((sizeof(unsigned long) * CHAR_BIT + 2) / 3 + 1 + 1)
+
+ #include "kpathsea/c-dir.h" /* dirent.h, NAMLEN */
+-
+-extern KPSEDLL char *kpathsea_version_string;
++#include "kpathsea/version.h"
+
+ #ifndef NeedFunctionPrototypes
+ # if __STDC__
diff --git a/app-text/xdvik/xdvik-22.84.16.ebuild b/app-text/xdvik/xdvik-22.84.16.ebuild
index e9ac2c04d297..d36a04fae5ae 100644
--- a/app-text/xdvik/xdvik-22.84.16.ebuild
+++ b/app-text/xdvik/xdvik-22.84.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xdvik/xdvik-22.84.16.ebuild,v 1.10 2010/10/02 13:13:03 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xdvik/xdvik-22.84.16.ebuild,v 1.11 2010/10/10 16:27:23 aballier Exp $
EAPI=3
inherit eutils flag-o-matic elisp-common toolchain-funcs
@@ -31,6 +31,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-open-mode.patch \
"${FILESDIR}"/${P}-cvararg.patch \
"${FILESDIR}"/${P}-parallel_make.patch
+ has_version '>=app-text/texlive-2009' && epatch "${FILESDIR}"/${P}-kpathsea_version.patch
# Make sure system kpathsea headers are used
cd "${WORKDIR}/${P}/texk/kpathsea"
for i in *.h ; do echo "#include_next \"$i\"" > $i; done