summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-12-18 15:45:53 +0000
committerMike Frysinger <vapier@gentoo.org>2002-12-18 15:45:53 +0000
commit9c13a665b50ae21eeb466b00829126b2a770ebb2 (patch)
tree7c6142aaa37a790e4b7181324eeb2a9b2b84ace3 /app-text
parentChanged einstall||die to einstall (diff)
downloadgentoo-2-9c13a665b50ae21eeb466b00829126b2a770ebb2.tar.gz
gentoo-2-9c13a665b50ae21eeb466b00829126b2a770ebb2.tar.bz2
gentoo-2-9c13a665b50ae21eeb466b00829126b2a770ebb2.zip
Changed econf||die to econf
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gtranslator/gtranslator-0.42.ebuild17
-rw-r--r--app-text/latex2html/latex2html-2002.1.ebuild17
2 files changed, 10 insertions, 24 deletions
diff --git a/app-text/gtranslator/gtranslator-0.42.ebuild b/app-text/gtranslator/gtranslator-0.42.ebuild
index 5b0feca5f8ff..15d5ca8abda3 100644
--- a/app-text/gtranslator/gtranslator-0.42.ebuild
+++ b/app-text/gtranslator/gtranslator-0.42.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gtranslator/gtranslator-0.42.ebuild,v 1.6 2002/12/09 04:17:44 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gtranslator/gtranslator-0.42.ebuild,v 1.7 2002/12/18 15:41:28 vapier Exp $
-IUSE="nls"
-
-S=${WORKDIR}/${P}
DESCRIPTION="A gettext po file editor for GNOME"
SRC_URI="http://www.gtranslator.org/download/releases/${PV}/${P}.tar.gz"
HOMEPAGE="http://www.gtranslator.org/"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 sparc "
+KEYWORDS="x86 sparc"
+IUSE="nls"
DEPEND=">=gnome-base/gnome-libs-1.2
=gnome-base/gconf-1.0*
@@ -23,27 +21,20 @@ DEPEND=">=gnome-base/gnome-libs-1.2
>=gnome-base/ORBit-0.5.14
>=gnome-base/gnome-vfs-1*
>=dev-libs/libxml-1.8.17"
-
RDEPEND="nls? ( sys-devel/gettext )"
src_compile() {
- local myconf
-
- use nls || myconf="--disable-nls"
-
- econf ${myconf} || die "./configure failed"
+ econf `use_enable nls`
emake || die
}
src_install() {
cd ${S}/help/C
-
mv Makefile Makefile.orig
sed -e 's:scrollkeeper-update.*::g' Makefile.orig > Makefile
rm Makefile.orig
cd ${S}
-
make DESTDIR=${D} install || die
dodoc ABOUT-NLS AUTHORS Changelog COPYING HACKING INSTALL NEWS README \
diff --git a/app-text/latex2html/latex2html-2002.1.ebuild b/app-text/latex2html/latex2html-2002.1.ebuild
index a1d4982a71e8..65216d39a851 100644
--- a/app-text/latex2html/latex2html-2002.1.ebuild
+++ b/app-text/latex2html/latex2html-2002.1.ebuild
@@ -1,21 +1,19 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/latex2html/latex2html-2002.1.ebuild,v 1.9 2002/12/09 04:17:44 manson Exp $
-
-IUSE="gif png"
+# $Header: /var/cvsroot/gentoo-x86/app-text/latex2html/latex2html-2002.1.ebuild,v 1.10 2002/12/18 15:45:53 vapier Exp $
MY_P=${P/./-}
S=${WORKDIR}/${MY_P}
DESCRIPTION="LATEX2HTML is a convertor written in Perl that converts LATEX documents to HTML."
SRC_URI="http://saftsack.fs.uni-bayreuth.de/~latex2ht/current/${MY_P}.tar.gz"
-HOMEPAGE="http://www.latex2html.org"
+HOMEPAGE="http://www.latex2html.org/"
SLOT="0"
LICENSE="as-is"
-KEYWORDS="x86 ppc sparc "
+KEYWORDS="x86 ppc sparc"
+IUSE="gif png"
DEPEND="sys-apps/supersed"
-
RDEPEND="app-text/ghostscript
app-text/tetex
media-libs/netpbm
@@ -25,7 +23,6 @@ RDEPEND="app-text/ghostscript
png? ( media-libs/libpng )"
src_compile() {
-
local myconf
use gif && myconf="${myconf} --enable-gif"
@@ -43,13 +40,12 @@ src_compile() {
--enable-paths \
--enable-wrapper"
- econf ${myconf} || die
+ econf ${myconf}
make || die
make check || die
}
-src_install () {
-
+src_install() {
dodir /usr/bin /usr/lib/latex2html /usr/share/latex2html
dodir /usr/share/texmf/tex/latex/html
cp cfgcache.pm cfgcache.pm.bak
@@ -71,7 +67,6 @@ src_install () {
doins .keep
# clean the perl scripts up to remove references to the sandbox
- einfo "fixing shit"
ssed -i "s:${T}::g" ${D}/usr/lib/latex2html/pstoimg.pl
ssed -i "s:${T}::g" ${D}/usr/lib/latex2html/latex2html.pl
ssed -i "s:${T}::g" ${D}/usr/lib/latex2html/cfgcache.pm