summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-01-12 20:19:19 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-01-12 20:19:19 +0000
commitc26916f5d7f74ca37db61b5fc29ba746f6a351e4 (patch)
tree7d48afe1bbc8d9e9072dd5350a8f3f80512f9688 /app-text
parentBlock kchart, so it is removed by portage (diff)
downloadgentoo-2-c26916f5d7f74ca37db61b5fc29ba746f6a351e4.tar.gz
gentoo-2-c26916f5d7f74ca37db61b5fc29ba746f6a351e4.tar.bz2
gentoo-2-c26916f5d7f74ca37db61b5fc29ba746f6a351e4.zip
Make it depend on dev-libs/chmlib[examples]. Bug #351321
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/chm2pdf/ChangeLog9
-rw-r--r--app-text/chm2pdf/chm2pdf-0.9.1-r1.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/app-text/chm2pdf/ChangeLog b/app-text/chm2pdf/ChangeLog
index c2076a78bf56..e8c597c42ad7 100644
--- a/app-text/chm2pdf/ChangeLog
+++ b/app-text/chm2pdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/chm2pdf
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/chm2pdf/ChangeLog,v 1.6 2010/05/04 17:11:30 hwoarang Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/chm2pdf/ChangeLog,v 1.7 2011/01/12 20:19:19 hwoarang Exp $
+
+*chm2pdf-0.9.1-r1 (12 Jan 2011)
+
+ 12 Jan 2011; Markos Chandras <hwoarang@gentoo.org> +chm2pdf-0.9.1-r1.ebuild:
+ Make it depend on dev-libs/chmlib[examples]. Bug #351321
04 May 2010; Markos Chandras <hwoarang@gentoo.org> chm2pdf-0.9.1.ebuild:
Inherit python eclass wrt bug #318403
diff --git a/app-text/chm2pdf/chm2pdf-0.9.1-r1.ebuild b/app-text/chm2pdf/chm2pdf-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..903e96c7efaa
--- /dev/null
+++ b/app-text/chm2pdf/chm2pdf-0.9.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/chm2pdf/chm2pdf-0.9.1-r1.ebuild,v 1.1 2011/01/12 20:19:19 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+inherit python eutils
+
+DESCRIPTION="A script that converts a CHM file into a single PDF file."
+HOMEPAGE="http://code.google.com/p/chm2pdf/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/pychm
+ app-text/htmldoc
+ dev-libs/chmlib[examples]"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare(){
+ epatch "${FILESDIR}/tempdir.patch"
+}
+
+src_install() {
+ dobin ${PN} || die "failed to create executable"
+ dodoc README || die "dodoc failed"
+}