summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-27 16:50:31 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-27 16:50:31 +0000
commitc4a014dc77d75aaaa6120abb48d29d753b8ccf69 (patch)
tree157a72defca379b46bde7e97738c22db846df2f7 /app-text
parentVersion bump for Gnome 3.12. (diff)
downloadgentoo-2-c4a014dc77d75aaaa6120abb48d29d753b8ccf69.tar.gz
gentoo-2-c4a014dc77d75aaaa6120abb48d29d753b8ccf69.tar.bz2
gentoo-2-c4a014dc77d75aaaa6120abb48d29d753b8ccf69.zip
Version bump to 1.8.0, continuation of app-text/mate-document-viewer.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/atril/ChangeLog9
-rw-r--r--app-text/atril/atril-1.8.0.ebuild101
-rw-r--r--app-text/atril/metadata.xml18
3 files changed, 128 insertions, 0 deletions
diff --git a/app-text/atril/ChangeLog b/app-text/atril/ChangeLog
new file mode 100644
index 000000000000..8b142f16b27d
--- /dev/null
+++ b/app-text/atril/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-text/atril
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/atril/ChangeLog,v 1.1 2014/04/27 16:50:31 tomwij Exp $
+
+*atril-1.8.0 (27 Apr 2014)
+
+ 27 Apr 2014; Tom Wijsman <TomWij@gentoo.org> +atril-1.8.0.ebuild,
+ +metadata.xml:
+ Version bump to 1.8.0, continuation of app-text/mate-document-viewer.
diff --git a/app-text/atril/atril-1.8.0.ebuild b/app-text/atril/atril-1.8.0.ebuild
new file mode 100644
index 000000000000..fe897bb7d381
--- /dev/null
+++ b/app-text/atril/atril-1.8.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/atril/atril-1.8.0.ebuild,v 1.1 2014/04/27 16:50:31 tomwij Exp $
+
+EAPI="5"
+
+ELTCONF="--portage"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="Atril document viewer for MATE"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="caja dbus debug djvu dvi +introspection gnome-keyring +ps t1lib tiff xps"
+
+RDEPEND=">=app-text/poppler-0.14:0=[cairo]
+ app-text/rarian:0
+ dev-libs/atk:0
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libxml2-2.5:2
+ >=mate-base/mate-desktop-1.6:0
+ sys-libs/zlib:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.21.5:2[introspection?]
+ x11-libs/libICE:0
+ >=x11-libs/libSM-1:0
+ x11-libs/libX11:0
+ >=x11-libs/cairo-1.9.10:0
+ x11-libs/pango:0
+ >=x11-themes/mate-icon-theme-1.6:0
+ caja? (
+ >=mate-base/caja-1.8:0[introspection?]
+ >=mate-base/mate-file-manager-1.6:0[introspection?]
+ )
+ djvu? ( >=app-text/djvu-3.5.17:0 )
+ dvi? (
+ virtual/tex-base:0
+ t1lib? ( >=media-libs/t1lib-5:5 )
+ )
+ gnome-keyring? ( >=app-crypt/libsecret-0.5:0 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6:0 )
+ ps? ( >=app-text/libspectre-0.2:0 )
+ tiff? ( >=media-libs/tiff-3.6:0 )
+ xps? ( >=app-text/libgxps-0.0.1:0 )
+ !!app-text/mate-document-viewer"
+
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools:0
+ >=app-text/scrollkeeper-dtd-1:1.0
+ >=dev-util/intltool-0.35:*
+ virtual/pkgconfig:*
+ sys-devel/gettext:*"
+
+# Tests use dogtail which is not available on Gentoo.
+RESTRICT="test"
+
+src_prepare() {
+ # Fix .desktop categories, upstream bug #666346.
+ sed -e "s:GTK\;Graphics\;VectorGraphics\;Viewer\;:GTK\;Office\;Viewer\;Graphics\;VectorGraphics;:g" -i data/atril.desktop.in.in || die
+
+ # Always autoreconf due to lib path conflict.
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Passing --disable-help would drop offline help, that would be inconsistent
+ # with helps of the most of GNOME apps that doesn't require network for that.
+ gnome2_src_configure \
+ --disable-tests \
+ --enable-comics \
+ --enable-pdf \
+ --enable-pixbuf \
+ --enable-thumbnailer \
+ --with-smclient=xsmp \
+ --with-platform=mate \
+ --with-gtk=2.0 \
+ $(use_enable dbus) \
+ $(use_enable djvu) \
+ $(use_enable dvi) \
+ $(use_with gnome-keyring keyring) \
+ $(use_enable introspection) \
+ $(use_enable caja) \
+ $(use_enable ps) \
+ $(use_enable t1lib) \
+ $(use_enable tiff) \
+ $(use_enable xps)
+}
+
+DOCS="AUTHORS NEWS README TODO"
diff --git a/app-text/atril/metadata.xml b/app-text/atril/metadata.xml
new file mode 100644
index 000000000000..12b09285ce38
--- /dev/null
+++ b/app-text/atril/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>TomWij@gentoo.org</email>
+ <name>Tom Wijsman</name>
+ </maintainer>
+ <use>
+ <flag name="caja">Enable property page extension in
+ <pkg>mate-base/mate-file-manager</pkg></flag>
+ <flag name="dvi">Enable build-in DVI viewer</flag>
+ <flag name="ps">Enable build-in postscript viewer</flag>
+ <flag name="t1lib">Enable the Type-1 fonts for the build-in DVI viewer
+ (<pkg>media-libs/t1lib</pkg>)</flag>
+ <flag name="xps">Enable XPS viewer using
+ <pkg>app-text/libxps</pkg></flag>
+ </use>
+</pkgmetadata>